r2#sh ip route
Codes: omitted
Codes: omitted
Gateway of last resort is not set
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/65] via 10.1.1.1, 00:02:53, Serial0/0
7.0.0.0/24 is subnetted, 1 subnets
C 7.7.7.0 is directly connected, Loopback7
9.0.0.0/24 is subnetted, 1 subnets
C 9.9.9.0 is directly connected, Loopback9
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/0
C 10.1.1.1/32 is directly connected, Serial0/0
r2#ping 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
r2#
Codes: omitted
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.1.1.1, 00:04:12, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
11.0.0.0/24 is subnetted, 1 subnets
C 11.1.1.0 is directly connected, Loopback1
r1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r1#
so i built loopbacks and ospf processes as seen below:
r3#sh run int lo3
Building configuration...
Current configuration : 83 bytes
!
interface Loopback3
ip vrf forwarding r1
ip address 3.3.3.3 255.255.255.0
end
r3#sh run int lo5
Building configuration...
Current configuration : 83 bytes
!
interface Loopback5
ip vrf forwarding r2
ip address 5.5.5.5 255.255.255.0
end
r3#
r3#sh run | begin ospf
router ospf 2 vrf r2
log-adjacency-changes
capability vrf-lite
network 3.3.3.0 0.0.0.255 area 0
network 5.5.5.0 0.0.0.255 area 0
network 10.1.1.0 0.0.0.255 area 0
!
router ospf 1 vrf r1
log-adjacency-changes
capability vrf-lite
network 3.3.3.0 0.0.0.255 area 0
network 5.5.5.0 0.0.0.255 area 0
network 10.1.1.0 0.0.0.255 area 0
!
as you can see i tried to route both loopbacks to both vrf's but that didn't seem to work, and i'm not that terribly interested... the router would only let me assign one address to one loopback vrf... maybe you could figure it out...
see below for the route tables per vrf...
r3#sh ip route vrf r1
Routing Table: r1
Codes: omitted
Routing Table: r1
Codes: omitted
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 10.1.1.2, 00:25:03, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback3
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
11.0.0.0/32 is subnetted, 1 subnets
O 11.1.1.1 [110/2] via 10.1.1.2, 00:25:03, FastEthernet0/0
r3#
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 10.1.1.2, 00:25:03, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback3
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
11.0.0.0/32 is subnetted, 1 subnets
O 11.1.1.1 [110/2] via 10.1.1.2, 00:25:03, FastEthernet0/0
r3#
r3#sh ip route vrf r2
Routing Table: r2
Codes: omitted
Routing Table: r2
Codes: omitted
Gateway of last resort is not set
5.0.0.0/24 is subnetted, 1 subnets
C 5.5.5.0 is directly connected, Loopback5
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/65] via 10.1.1.2, 00:23:17, Serial0/0
9.0.0.0/32 is subnetted, 1 subnets
O 9.9.9.9 [110/65] via 10.1.1.2, 00:23:17, Serial0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.2/32 is directly connected, Serial0/0
C 10.1.1.0/24 is directly connected, Serial0/0
r3#
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 9.9.9.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
r3#ping vrf r1 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r3#
and of course there are still no global routes, only vrf routes...
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
r3#
No comments:
Post a Comment