Pages

network cisco ccna gns3 certification arteq

network cisco ccna gns3 certification arteq
a network runs through it

Search insearchofthecert

Friday, August 31, 2012

doyle redist vol1 pg646...


h

int lo1
ip add 192.168.3.65 255.255.255.224
int lo2
ip add 192.168.3.97 255.255.255.224
int lo3
ip add 192.168.1.1 255.255.255.0

int f0/0
ip add 192.168.3.34 255.255.255.224
no shut

r

int f0/0
ip add 192.168.3.33 255.255.255.224
no shut

int f0/1
ip add 192.168.3.129 255.255.255.224
no shut

int s1/0
ip add 172.16.2.21 255.255.255.252
clock rat 128000
band 128
no shut

int s1/1
ip add 192.168.4.5 255.255.255.252
clock rat 128000
band 128
no shut

s

int lo1
172.16.1.1 255.255.255.0

int s1/0
ip add 172.16.2.22 255.255.255.252
band 128
no shut

c

int lo1
ip add 192.168.4.73 255.255.255.248

int s1/1
ip add 192.168.4.6 255.255.255.252
band 128
no shut

p

int lo1
ip add 192.168.3.161 255.255.255.224
int lo2
ip add 192.168.3.192 255.255.255.224
int lo3
ip add 192.168.2.1 255.255.255.0

int f0/1
ip add 192.168.3.130 255.255.255.252
band 128
no shut

good... ping the links...


doyle redist pg643...



m

int lo1
ip add 172.20.33.193 255.255.255.192
int lo2
ip add 172.20.35.1 255.255.255.0
int lo3
ip add 172.20.34.49 255.255.255.240

int f0/0
ip add 172.20.11.1 255.255.255.0
no shut

l

int f0/0
ip add 172.20.11.2 255.255.255.0
no shut

int f0/1
ip add 172.20.10.2 255.255.255.0
no shut

c

int lo1
ip add 172.20.20.1 255.255.255.0

int f0/1
ip add 172.20.10.1 255.255.255.0
no shut


routerm#sh run | beg ospf
router ospf 1
 network 172.20.11.0 0.0.0.255 area 0
 network 172.20.33.192 0.0.0.63 area 0
 network 172.20.34.48 0.0.0.15 area 0
 network 172.20.35.0 0.0.0.255 area 0

routerl#sh run | begin ospf
 router ospf 1
 network 172.20.11.0 0.0.0.255 area 0

routerl#sh run | beg eigrp
 router eigrp 1
 network 172.20.10.0 0.0.0.255
routerc#sh run | beg eigrp
router eigrp 1
 network 172.20.10.0 0.0.0.255
 network 172.20.20.0 0.0.0.255

router eigrp 1
redistribute ospf 1 metric 10000 100 255 1 15003
passive-interface f0/0
network 172.20.0.0

router ospf 1
redistribute eigrp 1 metric 30 metric-type 1 subnets
network 172.20.11.2 0.0.0.0 area 0

so this works nicely... a bit of overkill... i'll let doyle explain... the guy  really knows how to rap about this shit...

This configuration redistributes routes discovered by EIGRP process 1 into OSPF process 1. The metric portion of the command assigns an OSPF cost of 30 to each redistributed route. The redistribution makes Lajoie an ASBR in the OSPF domain, and the redistributed routes are advertised as external routes. The metric-type portion of the command specifies that the external type of the routes is E1. The subnets keyword, used only when redistributing routes into OSPF, specifies that subnet details will be redistributed. Without it, only major
network addresses are redistributed.

routerm#sh ip route | excl L | inc loop
      
Gateway of last resort is not set

      172.20.0.0/16 is variably subnetted, 10 subnets, 4 masks
O E1     172.20.10.0/24 [110/31] via 172.20.11.2, 00:18:57, FastEthernet0/0
C        172.20.11.0/24 is directly connected, FastEthernet0/0
O E1     172.20.20.0/24 [110/31] via 172.20.11.2, 00:15:55, FastEthernet0/0
C        172.20.33.192/26 is directly connected, Loopback1
C        172.20.34.48/28 is directly connected, Loopback3
C        172.20.35.0/24 is directly connected, Loopback2

routerc#sh ip route | excl L | incl loop
     
Gateway of last resort is not set

      172.20.0.0/16 is variably subnetted, 8 subnets, 2 masks
C        172.20.10.0/24 is directly connected, FastEthernet0/1
D EX     172.20.11.0/24
           [170/284160] via 172.20.10.2, 00:16:55, FastEthernet0/1
C        172.20.20.0/24 is directly connected, Loopback1
D EX     172.20.33.193/32
           [170/284160] via 172.20.10.2, 00:15:58, FastEthernet0/1
D EX     172.20.34.49/32
           [170/284160] via 172.20.10.2, 00:15:58, FastEthernet0/1
D EX     172.20.35.1/32

this command is really becoming a favorite for good reason... it just doesn't scrape very well...



this would be easier and the effect is the same....

redist eigrp 1 metric-type 1 sub





routerm#sh ip route | excl L | inc loop
      
Gateway of last resort is not set

      172.20.0.0/16 is variably subnetted, 10 subnets, 4 masks
O E1     172.20.10.0/24 [110/21] via 172.20.11.2, 00:02:30, FastEthernet0/0
C        172.20.11.0/24 is directly connected, FastEthernet0/0
O E1     172.20.20.0/24 [110/21] via 172.20.11.2, 00:02:30, FastEthernet0/0
C        172.20.33.192/26 is directly connected, Loopback1
C        172.20.34.48/28 is directly connected, Loopback3
C        172.20.35.0/24 is directly connected, Loopback2

add a new loopback to router c and advertise it with rip 2...

routerl#sh ip route | exc L | inc loop
      
Gateway of last resort is not set

      172.20.0.0/16 is variably subnetted, 9 subnets, 2 masks
C        172.20.10.0/24 is directly connected, FastEthernet0/1
C        172.20.11.0/24 is directly connected, FastEthernet0/0
D        172.20.20.0/24 [90/156160] via 172.20.10.1, 00:48:18, FastEthernet0/1
O        172.20.33.193/32 [110/2] via 172.20.11.1, 00:48:18, FastEthernet0/0
O        172.20.34.49/32 [110/2] via 172.20.11.1, 00:48:18, FastEthernet0/0
O        172.20.35.1/32 [110/2] via 172.20.11.1, 00:48:18, FastEthernet0/0
R        172.20.50.0/24 [120/1] via 172.20.10.1, 00:00:20, FastEthernet0/1

and redistribute into ospf... you could also include a default-metric value, like 68, ie...

router ospf 1
 redistribute eigrp 1 metric-type 1 subnets
 redistribute rip metric-type 1 subnets
 network 172.20.11.0 0.0.0.255 area 0
 default-metric 68

looks a little sexier...

routerm#sh ip route | excl L | inc loop
    
Gateway of last resort is not set

      172.20.0.0/16 is variably subnetted, 11 subnets, 4 masks
O E1     172.20.10.0/24 [110/69] via 172.20.11.2, 00:03:05, FastEthernet0/0
C        172.20.11.0/24 is directly connected, FastEthernet0/0
O E1     172.20.20.0/24 [110/69] via 172.20.11.2, 00:03:05, FastEthernet0/0
C        172.20.33.192/26 is directly connected, Loopback1
C        172.20.34.48/28 is directly connected, Loopback3
C        172.20.35.0/24 is directly connected, Loopback2
O E1     172.20.50.0/24 [110/69] via 172.20.11.2, 00:03:05, FastEthernet0/0

routerl#sh ip route | exc L | inc loop
     
Gateway of last resort is not set

      172.20.0.0/16 is variably subnetted, 9 subnets, 2 masks
C        172.20.10.0/24 is directly connected, FastEthernet0/1
C        172.20.11.0/24 is directly connected, FastEthernet0/0
D        172.20.20.0/24 [90/156160] via 172.20.10.1, 01:01:22, FastEthernet0/1
O        172.20.33.193/32 [110/2] via 172.20.11.1, 01:01:22, FastEthernet0/0
O        172.20.34.49/32 [110/2] via 172.20.11.1, 01:01:22, FastEthernet0/0
O        172.20.35.1/32 [110/2] via 172.20.11.1, 01:01:22, FastEthernet0/0
R        172.20.50.0/24 [120/1] via 172.20.10.1, 00:00:10, FastEthernet0/1

because you love rip...

the default will be 20 for ospf.. 69's kinda nice...



eigrp default-network...

this command does not work alone, nor does it really work at all...

two connected routers, two loopbacks, same AS, eigrp 1...

no default-network, no default route

r1(config)#router eigrp 1
r1(config-router)#netw 1.0.0.0
r1(config-router)#net 172.16.0.0
r1(config-router)#end
r1#
*Aug 31 11:39:02.867: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.2 (FastEthernet0/0) is up: new adjacency
*Aug 31 11:39:04.199: %SYS-5-CONFIG_I: Configured from console by console
r1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/20 ms
r1#

r1#sh ip route | ex L | inc loop
    
Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.1.1.0/24 is directly connected, Loopback0
      2.0.0.0/24 is subnetted, 1 subnets
D        2.2.2.0 [90/156160] via 172.16.1.2, 00:01:18, FastEthernet0/0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0

eigrp works as expected...  add a default route to the loopback...

r1(config)#ip route 0.0.0.0 0.0.0.0 lo0   
%Default route without gateway, if not a point-to-point interface, may impact performance
r1(config)#

note above error...

below, note gateway of last resort is set for the local router...

r1#sh ip route | ex L | inc loop
     
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Loopback0
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.1.1.0/24 is directly connected, Loopback0
      2.0.0.0/24 is subnetted, 1 subnets
D        2.2.2.0 [90/156160] via 172.16.1.2, 00:07:10, FastEthernet0/0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0

good... but the expected behavior when the ip default-network command is added in global configuration is for default route propagation in the AS...

r1(config)#ip default-netw 1.1.1.0
r1(config)#end

r2 does not get a hit...

r2#sh ip route | excl L | incl loop
     
Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
D        1.1.1.0 [90/156160] via 172.16.1.1, 00:09:12, FastEthernet0/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.2.2.0/24 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0

take away the default-network command and you lose the candidate static...

add a default network in eigrp...

r1(config)#router eigrp 1
r1(config-router)#netw 0.0.0.0
r1(config-router)#end

r2#sh ip route | excl L | incl loop
     
Gateway of last resort is 172.16.1.1 to network 0.0.0.0

D*    0.0.0.0/0 [90/156160] via 172.16.1.1, 00:00:50, FastEthernet0/0
      1.0.0.0/24 is subnetted, 1 subnets
D        1.1.1.0 [90/156160] via 172.16.1.1, 00:15:18, FastEthernet0/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.2.2.0/24 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/0

would someone please tell me what the command ip default-network in eigrp does except create a candidate static on the local router and give me a big friggin headache...

ip default-network 1.0.0.0


this command also changes nothing...

of course i didn't want someone to get hysterical on me so i did the same exercise with real equipment...

i added a default route between 2 routers and the result was the same... the default showed up in the route table on the local router...

r1#sh ip route                                                                 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP                 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area          
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2          
       E1 - OSPF external type 1, E2 - OSPF external type 2                    
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2   
       ia - IS-IS inter area, * - candidate default, U - per-user static route 
       o - ODR, P - periodic downloaded static route                           
                                                                               
Gateway of last resort is 0.0.0.0 to network 0.0.0.0                           
                                                                               
     1.0.0.0/24 is subnetted, 1 subnets                                        
C       1.1.1.0 is directly connected, Loopback0                               
     2.0.0.0/24 is subnetted, 1 subnets                                        
D       2.2.2.0 [90/40640000] via 192.168.100.2, 00:01:17, Serial0/0           
     192.168.100.0/28 is subnetted, 1 subnets                                  
C       192.168.100.0 is directly connected, Serial0/0                         
S*   0.0.0.0/0 is directly connected, Loopback0       

and no gateway as expected...

r2#sh ip route                                                                 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP                 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area          
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2          
       E1 - OSPF external type 1, E2 - OSPF external type 2                    
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2   
       ia - IS-IS inter area, * - candidate default, U - per-user static route 
       o - ODR, P - periodic downloaded static route                           
                                                                               
Gateway of last resort is not set                                              
                                                                               
     1.0.0.0/24 is subnetted, 1 subnets                                        
D       1.1.1.0 [90/40640000] via 192.168.100.1, 00:03:55, Serial0/0           
     2.0.0.0/24 is subnetted, 1 subnets                                        
C       2.2.2.0 is directly connected, Loopback0   

then i added the ip default-network command...

r1(config)#ip default-netw 1.0.0.0                                             
r1(config)#end                                                                 
r1#sh i                                                                        
*Jul 22 10:22:22.439: %SYS-5-CONFIG_I: Configured from console by console      
r1#sh ip route                                                                 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP                 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area          
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2          
       E1 - OSPF external type 1, E2 - OSPF external type 2                    
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2   
       ia - IS-IS inter area, * - candidate default, U - per-user static route 
       o - ODR, P - periodic downloaded static route                           
                                                                               
Gateway of last resort is 0.0.0.0 to network 0.0.0.0                           
                                                                               
 *   1.0.0.0/24 is subnetted, 1 subnets                                        
C       1.1.1.0 is directly connected, Loopback0                               
     2.0.0.0/24 is subnetted, 1 subnets                                        
D       2.2.2.0 [90/40640000] via 192.168.100.2, 00:05:08, Serial0/0           
     192.168.100.0/28 is subnetted, 1 subnets                                  
C       192.168.100.0 is directly connected, Serial0/0                         
S*   0.0.0.0/0 is directly connected, Loopback0                                
r1#

r2#sh ip route                                                                 
                                                                               
Gateway of last resort is not set                                              
                                                                               
     1.0.0.0/24 is subnetted, 1 subnets                                        
D       1.1.1.0 [90/40640000] via 192.168.100.1, 00:06:26, Serial0/0           
     2.0.0.0/24 is subnetted, 1 subnets                                        
C       2.2.2.0 is directly connected, Loopback0       

of course not...

then i added the network 0.0.0.0 in eigrp on r1 and...

r2#sh ip route                                                            
                                                                        
Gateway of last resort is 192.168.100.1 to network 0.0.0.0                     
                                                                               
     1.0.0.0/24 is subnetted, 1 subnets                                        
D       1.1.1.0 [90/40640000] via 192.168.100.1, 00:07:43, Serial0/0           
     2.0.0.0/24 is subnetted, 1 subnets                                        
C       2.2.2.0 is directly connected, Loopback0      

like magic, the gateway appeared... you can also perform this with redistribution static in eigrp but that yeilds an external route with an AD of 170...

the ip default-network command does not alone propagate a default-network in an eigrp AS...

so there... thanks for ruining my day eigrp...

    

Thursday, August 30, 2012

slimed eigrp case study...

a downloaded pdf slimed from somewhere on the internet, below...

i needed a break from doyle...


this is the mission...

The ITA core network is running EIGRP in AS 1.

Summarize the loopback interfaces on R2 with the best possible summary to the other EIGRP routers

Loopback 192 on R3 represents a connection to the Internet. Originate a default route into EIGRP from R3.

The Local Travel Agency router, R4, needs to communicate with the ITA core via OSPF area 0.

Redistribute OSPF into EIGRP.

Originate a default route into the OSPF process from R3.

Configure R2 to act as a DHCP server on the Ethernet subnet between R2 and R3.

mine's prettier...



r1

int lo1
ip add 192.168.1.1 255.255.255.252

int s1/2
ip add 192.168.1.129 255.255.255.252
clock rat 128000
band 128
no shut

int s1/3
ip add 192.168.1.133 255.255.255.252
clock rat 128000
band 128
no shut

r2

int lo101
ip add 192.168.1.101 255.255.255.252
int lo105
ip add 192.168.1.105 255.255.255.252
int lo109
ip add 192.168.1.109 255.255.255.252
int lo113
ip add 192.168.1.113 255.255.255.252

int s1/2
ip add 192.168.1.130 255.255.255.252
band 128
no shut

int f0/0
ip add 192.168.1.161 255.255.255.224
no shut

r3

int lo5
ip add 192.168.1.5 255.255.255.252
int lo192
ip add 192.168.100.1 255.255.255.0

int f0/0
ip add 192.168.1.162 255.255.255.224
no shut

int s1/0
ip add 10.1.1.3 255.255.255.248
clock rat 128000
band 128
no shut

int s1/3
ip add 192.168.1.134 255.255.255.252
band 128000
no shut

r4

int lo4
ip add 10.4.4.4 255.255.255.0

int s1/0
ip add 10.1.1.4 255.255.255.248
band 128
no shut

ping what you can...

r1#sh run | beg router
router eigrp 1
 network 192.168.1.0 0.0.0.3
 network 192.168.1.128 0.0.0.3

r2#sh run | beg router
router eigrp 1
 network 192.168.1.100 0.0.0.3
 network 192.168.1.104 0.0.0.3
 network 192.168.1.108 0.0.0.3
 network 192.168.1.112 0.0.0.3
 network 192.168.1.128 0.0.0.3
 network 192.168.1.160 0.0.0.3

r3#sh run | begin router
router eigrp 1
 network 192.168.1.4 0.0.0.3
 network 192.168.1.132 0.0.0.3
 network 192.168.1.160 0.0.0.31
 network 192.168.100.0

r2#sh ip route | excl L | incl loop


Gateway of last resort is not set

      192.168.1.0/24 is variably subnetted, 15 subnets, 3 masks
D        192.168.1.0/30 [90/20640000] via 192.168.1.129, 00:13:37, Serial1/2
D        192.168.1.4/30
           [90/156160] via 192.168.1.162, 00:08:13, FastEthernet0/0
C        192.168.1.100/30 is directly connected, Loopback101
C        192.168.1.104/30 is directly connected, Loopback105
C        192.168.1.108/30 is directly connected, Loopback109
C        192.168.1.112/30 is directly connected, Loopback113
C        192.168.1.128/30 is directly connected, Serial1/2
D        192.168.1.132/30
           [90/540160] via 192.168.1.162, 00:08:13, FastEthernet0/0
C        192.168.1.160/27 is directly connected, FastEthernet0/0
D     192.168.100.0/24
           [90/156160] via 192.168.1.162, 00:08:13, FastEthernet0/0





doyle chap 4 case totally stubby...

we follow the last post with a step farther...

we can make router r totally stubby by eliminating  two of the summary lsa's...


area 1 stub no-summary

just add it on the abr...

see ya...

and the ia's too...

r#sh ip route | excl L | incl loop
       
Gateway of last resort is 192.168.30.10 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/782] via 192.168.30.10, 00:08:43, Serial1/1
      192.168.30.0/24 is variably subnetted, 4 subnets, 2 masks
C        192.168.30.0/29 is directly connected, Loopback0
C        192.168.30.8/29 is directly connected, Serial1/1

doyle ospf chap 4 case stub...

how's your stub...

add router, r5 to the topology...

spin up eigrp, add f0/0 and the loopbacks...

router eigrp 1
 network 1.0.0.0
 network 2.0.0.0
 network 172.16.0.0

m#sh run | beg eigrp
router eigrp 1
 network 172.16.0.0

before redistribution, check the lsa's on r

r#sh ip ospf data data

            OSPF Router with ID (192.168.30.1) (Process ID 10)

Area 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       0        0        0      
  Summary Net   2        0        0      
  Summary ASBR  1        0        0      
  Type-7 Ext    0        0        0      
    Prefixes redistributed in Type-7  0
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      5        0        0      

Process 10 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       0        0        0      
  Summary Net   2        0        0      
  Summary ASBR  1        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    0        0        0      
      Prefixes redistributed in Type-5  0
  Opaque AS     0        0        0      
  Non-self      4      
  Total         5        0        0     

now redistribute...

router ospf 40
 redistribute eigrp 1 metric 1 subnets
 network 192.168.10.0 0.0.0.31 area 192.168.10.0

notice the single type 4 and 3 type 5's in the output... see table above for explanation...

area 1 is not originating external lsa's and is therefore candidate as a stub...

make area 1 a stub...

on routers r and  c add area 1 stub to each configuration...
seems insignificant for a small topology, but in a larger one, the reduction of lsa's could prove useful...

compare after the adjacency change... note the addition of a summary net (type 3) and the elimination of the single type 4 and the 3  5's...


it also now advertises a default route via the added summary lsa...

r#sh ip route | excl L | incl loop

Gateway of last resort is 192.168.30.10 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/782] via 192.168.30.10, 00:07:09, Serial1/1
      192.168.10.0/27 is subnetted, 1 subnets
O IA     192.168.10.0 [110/2343] via 192.168.30.10, 00:07:09, Serial1/1
      192.168.20.0/30 is subnetted, 1 subnets
O IA     192.168.20.0 [110/1562] via 192.168.30.10, 00:07:09, Serial1/1
      192.168.30.0/24 is variably subnetted, 4 subnets, 2 masks
C        192.168.30.0/29 is directly connected, Loopback0
C        192.168.30.8/29 is directly connected, Serial1/1

they remain e2's on router g of course...

g#sh ip route

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
O E2     1.1.1.0 [110/1] via 192.168.10.2, 00:32:37, Serial1/3
      2.0.0.0/24 is subnetted, 1 subnets
O E2     2.2.2.0 [110/1] via 192.168.10.2, 00:32:37, Serial1/3
      172.16.0.0/24 is subnetted, 1 subnets
O E2     172.16.1.0 [110/1] via 192.168.10.2, 00:32:37, Serial1/3
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/27 is directly connected, Serial1/3
L        192.168.10.1/32 is directly connected, Serial1/3
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/30 is directly connected, Serial1/2
L        192.168.20.2/32 is directly connected, Serial1/2
      192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
O IA     192.168.30.1/32 [110/1563] via 192.168.20.1, 00:21:10, Serial1/2
O IA     192.168.30.8/29 [110/1562] via 192.168.20.1, 03:49:31, Serial1/2


doyle ospf chap 4 case 2...

to rid or not to rid...

it is evident that the router id, if changed on an active ospf process, will not alter the current rid in the process... the process needs to be shut down for this to be changed... there is no argument against the validity of either using the highest (if configured) loopback or a manual rid to protect the ospf process... also, once established as the rid, a loopback in shutdown will still remain the rid so long as the process isn't restarted...

we know it is important that the ospf process not be saddled with a rid dependant on the state of an interface that may be subject to shutdown (interface failure)

we also understand that a manual rid is simply an ospf process identifier and has nothing to do with the state of routing for the process...

for the example, loopbacks are added, and only the network statement for router r is changed as more specific...



r

interface Loopback0

ip address 192.168.50.1 255.255.255.255

outer ospf 10

network 192.168.30.0 0.0.0.255 area 1

c

interface Loopback0

ip address 192.168.50.2 255.255.255.255

g

interface Loopback0

ip address 192.168.50.3 255.255.255.255

m

ip address 192.168.50.4 255.255.255.255

note how doyle chooses a uniform scheme...

the simple presence of the loopback does not automatically change the rid...

r#sh ip ospf

 Routing Process "ospf 10" with ID 192.168.30.9

nor is it changed at the neighbor...

c#sh ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface

192.168.20.2      0   FULL/  -        00:00:33    192.168.20.2    Serial1/2

192.168.30.9      0   FULL/  -        00:00:36    192.168.30.9    Serial1/1

the process for router r is closed, and in a few moments, the id expires on the neighbor...

c#sh ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface

192.168.20.2      0   FULL/  -        00:00:34    192.168.20.2    Serial1/2

lacking a manual rid, once the process is brought back the highest loopback is reflected in the topology...

r#sh ip ospf

 Routing Process "ospf 10" with ID 192.168.50.1

c#sh ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface

192.168.20.2      0   FULL/  -        00:00:37    192.168.20.2    Serial1/2

192.168.50.1      0   FULL/  -        00:00:33    192.168.30.9    Serial1/1

the importance of this cannot be understated... a common practice is to use public ip addresses for loopbacks such as 1.1.1.1 for router1, 2.2.2.2 for router2, etc.  the threat here is internet leakage because the ip's are public, however...

manual id's are perhaps the best choice; i prefer loopbacks because they perform double duty... when the ospf process comes back, at least one interface needs to be active... the manual id is of course, not an interface...

Wednesday, August 29, 2012

doyle ospf chap 4 case 1... watch out...


r

int lo0
ip add 192.168.30.1 255.255.255.248

int s1/1
ip add 192.168.30.9 255.255.255.248
clock rat 128000
band 128
no shut


c

int s1/1
ip add 192.168.30.10 255.255.255.248
band 128
no shut


int s1/2
ip add 192.168.20.1 255.255.255.252
clock rat 128000
band 128
no shut

g

int s1/2
ip add 192.168.20.2 255.255.255.252
band 128
no shut

int s1/3
ip add 192.168.10.1 255.255.255.224
clock rat 128000
band 128
no shut

m

int lo0
ip add 192.168.10.65 255.255.255.192

int lo1
ip add 192.168.10.33 255.255.255.240

int s1/3
ip add 192.168.10.2 255.255.255.224
band 128
no shut

the following is a demonstration of the flexibility in the network command...

r

router ospf 10
netw 0.0.0.0 255.255.255.255 area 1

c

router ospf 20

netw 192.168.20.0 0.0.0.255 area 0
netw 192.168.30.0 0.0.0.255 area 1

g

router ospf 30
netw 192.168.20.0 0.0.0.3 area 0.0.0.0
netw 192.168.10.0 0.0.0.31 area 192.168.10.0

m
router ospf 40
netw 192.168.10.2 0.0.0.0 area 192.168.10.0
netw 192.168.10.33 0.0.0.0 area 192.168.10.0

it's ok... jeff doyle is insane and so are you...


m# sh ip route | exc L |inc loop
     
Gateway of last resort is not set

      192.168.10.0/24 is variably subnetted, 6 subnets, 4 masks
C        192.168.10.0/27 is directly connected, Serial1/3
C        192.168.10.32/28 is directly connected, Loopback1
C        192.168.10.64/26 is directly connected, Loopback0
      192.168.20.0/30 is subnetted, 1 subnets
O IA     192.168.20.0 [110/1562] via 192.168.10.1, 00:00:33, Serial1/3
      192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
O IA     192.168.30.1/32 [110/2344] via 192.168.10.1, 00:00:33, Serial1/3
O IA     192.168.30.8/29 [110/2343] via 192.168.10.1, 00:00:33, Serial1/3

m#ping 192.168.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/20 ms

naturally you have a preferred method of tapping out  network statements, as i do...  and speed is important... this was not speedy, at all...

i think jeff doyle is the red knight...

you really have to read the guy... i will not attempt to paraphrase; it is so well done i wouldn't dare... vol 1 pg413... no wonder this is on everyone's digital bookshelf...

note that although lo0 on router m does not participate in ospf it is yet the router id... when was the last time you used this command?


m#sh ip ospf 40
 Routing Process "ospf 40" with ID 192.168.10.65
 Start time: 00:40:44.000, Time elapsed: 00:21:26.372
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Supports NSSA (compatible with RFC 3101)
 Event-log enabled, Maximum number of events: 1000, Mode: cyclic
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
 IETF NSF helper support enabled
 Cisco NSF helper support enabled
 Reference bandwidth unit is 100 mbps
    Area 192.168.10.0
        Number of interfaces in this area is 2 (1 loopback)
    Area has no authentication
    SPF algorithm last executed 00:21:21.280 ago
    SPF algorithm executed 1 times
    Area ranges are
    Number of LSA 5. Checksum Sum 0x029BF1
    Number of opaque link LSA 0. Checksum Sum 0x000000
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0

proof that you can't simply read the book... you have to be the book...

found lab 1... routemybrain

what i do when i set up a lab in gns3...

1.  open always as a project, click the save boxes and give it the correct absolute path to save... very important...
2. add devices to the topology, configure devices and add connections...
3. label topology
4. check numbers for consistency against diagram/resource
try to be consistent with interfaces, ie. r1 --> r2 is s1/1 to s1/1 et al, f0/0 --> f0/0 whenever possible
5. turn on devices, open all consoles and cascade console windows
6. start with device 1, hostname, then scrape:

 line con 0
 exec-timeout 0 0
 privilege level 15
 password ccie
 logging synchronous
 login
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password ccie
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 password ccie
 logging synchronous
 login

add ser time deb dat and ser time log dat, gns3 always has clock set so no need for that... cop r s
7. next device repeat 6, then set debug level 3 in console window of gns3, file save, and check that configs have exported to correct path...
8. add ip's and other information that is generic to that lab, meaning, that keeps the lab vanilla... verify connectivity, then save... this is the last save... do not save further configuration such as routing protocols, or enhancements of any kind...

the idea is that you want to open it again in the future without doing the manual labor of building it from the ground up, but saving routing config for your session... keep the base pristine...

here is a topology from routemybrain... let's see what this guy's got...

http://www.routemybrain.com/gns3-ospf-practice-lab-for-ccna-and-ccnp-route/

these are his demands...

1.)Configure OSPF on all the routers with appropriate network commands.
2.)Configure R2 to summarize area 20 with the most specific mask.
3.)Configure R1 to always originate default route.
4.)Change hello and dead timers between R2 and R3 to your desired value. Make the network type between R1 and R2 as point-to-point with R1 as the DR.
5.)Make area 34 as totally stub area.
6.)Use MD5 between R2 and R3 with routemybrain.com as password icon smile GNS3 OSPF Practice Lab For CCNA and CCNP ROUTE
7.)Find why R1 is not able to ping the R4. ( FIX THIS PROBLEM)

the interface configs (i've already adjusted the numbering to suit my topology, and stripped any preconfig)...


in red are my fixes...  routemybrain is not routing my brain out  the gate... he should change his site name to lostmybrain...

r1

interface Loopback0
ip address 172.16.2.1 255.255.255.0

interface Serial1/1
ip address 172.16.13.3 255.255.255.0
clock rat 128000
band 128000
no shut
r2

interface Loopback0
ip address 172.16.3.1 255.255.255.224
interface Loopback1
ip address 172.16.3.33 255.255.255.224
interface Loopback2
ip address 172.16.3.65 255.255.255.224
interface Loopback3
ip address 172.16.3.97 255.255.255.224

interface Serial1/1
ip address 172.16.13.2 255.255.255.0
band 128
no shut

interface Serial1/2
ip address 172.16.24.2 255.255.255.0
clock rat 128000
band 128
no shut


r3


interface Loopback0
ip address 172.16.4.1 255.255.255.0

interface Serial1/2
ip address 172.16.24.3 255.255.255.0
band 128
no shut

interface Serial1/3
ip address 172.16.35.3 255.255.255.0
clock rat 128000
band 128
no shut


r4


interface Loopback0
ip address 172.16.5.1 255.255.255.0

interface Serial1/3
ip address 172.16.35.2 255.255.255.0
band 128
no shut


cop r s

last save, and you'll be able to work it again..

the pings to directly connected networks are good... he got the addressing correct...two stars...

r4#ping 172.16.35.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.35.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/16 m

r3#ping 172.16.24.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.24.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 r2#ping 172.16.13.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms

i thought i recognized this so i checked and this is the challenge lab from netacad route manual... o well...next...

i'm not giving the answers by the way... it's a challenge...

lab 8-3 II...

from stretch at packetlife...

 http://packetlife.net/blog/2010/mar/15/6to4-ipv6-tunneling/

"6to4 tunneling" is an IPv6 transition mechanism described in RFC 3056. Like many other transition mechanisms, it enables encapsulation of IPv6 packets into IPv4 for transport across an IPv4 network. What's really neat about 6to4 is that it allows for automatic IPv6-to-IPv4 address translation, and treats the underlying IPv4 network as one big non-broadcast multiaccess (NBMA) network, rather than a collection of independent point-to-point links.

he said "neat"...



 add the other loopbacks...

r1

int lo11
ipv6 add 2002:ac10:0c01:11::1/64

int lo12
ipv6 add 2002:ac10:0c01:12::1/64

r3

int lo31
ipv6 add 2002:ac10:1703:31::1/64

int lo32
ipv6 add 2002:ac10:1703:32::1/64

why does 172.16.12.1 = ac10:0c01

ac = 172 because 10X16 = 160 + 12 = 172
10 = 16 or one 16 in the 16's place holder
0c = 12
01 = 1

for a review of hex go here...
http://insearchofthecert.blogspot.com/2012/04/hex.html

set up the tunnels... pay particular attention to the ipv6 addresses...

r1

int tun0
tunnel mode ipv6ip 6to4
ipv6 add 2002:ac10:0c01:1::1/64
tunnel source serial1/1
exit

turn on v6 routing and a static route for the entire 2002::/16 network...

ipv6 unicast-routing
ipv6 route 2002::/16 tunnel0

r3

int tun0
tunnel mode ipv6ip 6to4
ipv6 add 2002:ac10:1703:1::3/64
tunnel source serial1/2
exit

ipv6 unicast-routing
ipv6 route 2002::/16 tunnel0

foreach address {
2002:ac10:1703:1::3
2002:ac10:1703:31::1
2002:ac10:1703:32::1
2002:ac10:c01:1::1
2002:ac10:c01:11::1
2002:ac10:c01:12::1
} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:1::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:31::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:1703:32::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:11::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:AC10:C01:12::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 add static routes... just like v4...

r1

ipv6 route fec0::3:0/112 2002:ac10:1703:1::3

r3

ipv6 route fec0::1:0/112 2002:ac10:c01:1::1


r3#sh ipv6 route
IPv6 Routing Table - default - 11 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
S   2002::/16 [1/0]
     via Tunnel0, directly connected
C   2002:AC10:1703:1::/64 [0/0]
     via Tunnel0, directly connected
L   2002:AC10:1703:1::3/128 [0/0]
     via Tunnel0, receive
C   2002:AC10:1703:31::/64 [0/0]
     via Loopback31, directly connected
L   2002:AC10:1703:31::1/128 [0/0]
     via Loopback31, receive
C   2002:AC10:1703:32::/64 [0/0]
     via Loopback32, directly connected
L   2002:AC10:1703:32::1/128 [0/0]
     via Loopback32, receive
S   FEC0::1:0/112 [1/0]
     via 2002:AC10:C01:1::1
C   FEC0::3:0/112 [0/0]
     via Loopback0, directly connected
L   FEC0::3:1/128 [0/0]
     via Loopback0, receive
L   FF00::/8 [0/0]
     via Null0, receive
r3#

25 or 6to4...

which is it?


r1

int lo0
ip add 10.1.1.1 255.255.255.0
ipv6 add fec0::1:1/112

int s1/1
ip add 172.16.12.1 255.255.255.0
clock rat 64000
band 64
no shut

r2

int lo0
ip add 10.1.2.1 255.255.255.0

int s1/1
ip add 172.16.12.2 255.255.255.0
band 64
no shut

int s1/2
ip add 172.16.23.2 255.255.255.0
clock rat 64000
band 64
no shut

r3

int lo0
ip add 10.1.3.1 255.255.255.0
ipv6 add fec0::3:1/112

int s1/2
ip add 172.16.23.3 255.255.255.0
band 64
no shut

r1#ping 172.16.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/16 ms

r3#ping 172.16.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/16 ms

load up on eigrp 

router eigrp 1
no auto-summ
netw 10.0.0.0
netw 172.16.0.0

r3#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/24 ms


r3#sh ip route eigrp

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D        10.1.1.0/24 [90/41152000] via 172.16.23.2, 00:00:54, Serial1/2
D        10.1.2.0/24 [90/40640000] via 172.16.23.2, 00:00:54, Serial1/2
      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D        172.16.12.0/24 [90/41024000] via 172.16.23.2, 00:00:54, Serial1/2