on r1
interface Loopback1
ip address 10.1.1.1 255.255.224.0
!
interface Loopback33
ip address 10.1.33.1 255.255.224.0
!
interface Loopback65
ip address 10.1.65.1 255.255.224.0
!
interface Loopback97
ip address 10.1.97.1 255.255.224.0
!
ip address 10.1.1.1 255.255.224.0
!
interface Loopback33
ip address 10.1.33.1 255.255.224.0
!
interface Loopback65
ip address 10.1.65.1 255.255.224.0
!
interface Loopback97
ip address 10.1.97.1 255.255.224.0
!
interface Loopback161
ip address 10.1.161.1 255.255.224.0
ip address 10.1.161.1 255.255.224.0
on r2
r2(config)#int lo1
r2(config-if)#ip add 10.2.1.1 255.255.224.0
r2(config-if)#int lo33
r2(config-if)#ip add 10.2.33.1 255.255.224.0
r2(config-if)#int lo65
r2(config-if)#ip add 10.2.65.1 255.255.224.0
r2(config-if)#int lo97
r2(config-if)#ip add 10.2.97.1 255.255.224.0
r2(config-if)#int lo129
r2(config-if)#ip add 10.1.129.1 255.255.224.0
r2(config-if)#int lo161
r2(config-if)#ip add 10.2.161.1 255.255.224.0
on r4
interface Loopback1
ip address 10.3.1.1 255.255.224.0
!
interface Loopback33
ip address 10.3.33.1 255.255.224.0
!
interface Loopback65
ip address 10.3.65.1 255.255.224.0
!
interface Loopback97
ip address 10.3.97.1 255.255.224.0
!
interface Loopback129
ip address 10.3.129.1 255.255.224.0
!
interface Loopback161
ip address 10.3.161.1 255.255.224.0
set up the frame switch...
r3fr#sh run (only essential config is shown)
hostname r3fr
!
frame-relay switching
!
interface Serial1/0
no ip address
encapsulation frame-relay IETF
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial1/1 103
!
interface Serial1/1
no ip address
encapsulation frame-relay IETF
clockrate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial1/2 201
frame-relay route 103 interface Serial1/0 301
!
interface Serial1/2
no ip address
encapsulation frame-relay IETF
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial1/1 102
then set up the interfaces on the various routers...
r1#sh run int s1/1
Building configuration...
Current configuration : 222 bytes
!
interface Serial1/1
ip address 172.16.124.1 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
no frame-relay inverse-arp
Building configuration...
Current configuration : 222 bytes
!
interface Serial1/1
ip address 172.16.124.1 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
no frame-relay inverse-arp
r2#sh run int s1/2
Building configuration...
Current configuration : 212 bytes
!
interface Serial1/2
ip address 172.16.124.2 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.3 201
no frame-relay inverse-arp
Building configuration...
Current configuration : 212 bytes
!
interface Serial1/2
ip address 172.16.124.2 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.3 201
no frame-relay inverse-arp
Building configuration...
Current configuration : 212 bytes
!
interface Serial1/0
ip address 172.16.124.3 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.1 301 broadcast
frame-relay map ip 172.16.124.2 301
no frame-relay inverse-arp
every body ping everybody...
r1#ping 172.16.124.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r1#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r1#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/40 ms
r2#ping 172.16.124.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r2#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r2#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
r4#ping 172.16.124.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/37/56 ms
if you want the routers to ping themselves, add maps to their own addresses... i'm not interested...
as was discussed in an earlier lab, bandwidth should match the clock rate... since we are in mr. mcfeely's frame relay land of make believe, do it on the interfaces you can control...
r1#sh run int s1/1 | incl bandwidth
bandwidth 128
bandwidth 128
r2#sh run int s1/2 | incl band
bandwidth 64
bandwidth 64
bandwidth 64
oh boy... we get to turn off auto-summ this time... this is very exciting...
set up eigrp for the major networks...
r1#sh run | begin router
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
do this for r2 and r4 as well... go ahead and scrape... you know you will...
the ip route table for r1 looks good...
r1#sh ip route eigrp
10.0.0.0/19 is subnetted, 17 subnets
D 10.2.0.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.0.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.32.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.32.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.64.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.64.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.96.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.96.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.3.128.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.1.128.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.2.160.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.160.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
10.0.0.0/19 is subnetted, 17 subnets
D 10.2.0.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.0.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.32.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.32.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.64.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.64.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.96.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.96.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.3.128.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.1.128.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.2.160.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.160.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
but r2 is looking kinda weak...
r2# sh ip route eigrp
10.0.0.0/19 is subnetted, 11 subnets
D 10.1.0.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.32.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.64.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.96.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.160.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
r2#
i know you know what's coming... the big no ip split horizon trick... oooooooooooooooooooooooohhhhhhhhhhhhhhhhhhhh...
r1(config)#int s1/1
r1(config-if)#no ip split-horizon eigrp 1
r1(config-if)#no ip split-horizon eigrp 1
IP-EIGRP Route Events debugging is on
00:43:40: IP-EIGRP: 10.2.0.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.0.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.32.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.32.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.64.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.64.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.96.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.96.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.1.128.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.1.128.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.160.0/19
r2#sh - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.160.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 172.16.124.0/29 - do advertise out Serial1/2
00:43:42: IP-EIGRP: Processing incoming UPDATE packet
00:43:42: IP-EIGRP: Int 10.1.0.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.32.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.64.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.96.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.160.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 172.16.124.0/29 M 41024000 - 40000000 1024000 SM 20512000 - 20000000 512000
00:43:42: IP-EIGRP: 172.16.124.0/29 routing table not updated
00:43:42: IP-EIGRP: Int 10.1.0.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 10.1.32.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 1
r2#sh 0.1.64.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 10.1.96.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 10.1.160.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Processing incoming UPDATE packet
00:43:42: IP-EIGRP: Int 10.2.0.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.0.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.32.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.32.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.64.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.64.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.96.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.96.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.1.128.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.
r2#sh 1.128.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.160.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.160.0/19 routing table not updated
r2#
it's a twofer...
r2# sh ip route eigrp
10.0.0.0/19 is subnetted, 17 subnets
D 10.3.0.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.0.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.32.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.32.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.64.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.64.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.96.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.96.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.128.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.3.160.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.160.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
the book wants to run a tcl script to ping everybody... go ahead...
ok so we know split horizon is on by default and it makes frame misbehave...
who still uses frame?
word is they hang on to frame as a testable subject because it makes routing protocols do weird shit... great...
i made the multicast hello's into unicast with this...
router eigrp 1
network 10.0.0.0
network 172.16.0.0
neighbor 172.16.124.3 Serial1/1
neighbor 172.16.124.2 Serial1/1
no auto-summary
and proved it with some caps below... note destinations, before and after...
No comments:
Post a Comment