the switch is zeroized to vlan 1... i gave it a management ip of :
vlan1#sh ip int brie
Interface IP-Address OK? Method Status Prol
Vlan1 10.1.100.99 YES manual up up
FastEthernet0/1 unassigned YES unset up up
FastEthernet0/2 unassigned YES unset up up
FastEthernet0/3 unassigned YES unset up up
and put r1, r2, r3 in ports f0/1 - 3... go figure...
r1
interface Loopback1
description engineering
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.1 255.255.255.0
duplex auto
speed auto
r2
interface Loopback2
description marketing
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.2 255.255.255.0
duplex auto
speed auto
r3
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.3 255.255.255.0
duplex auto
speed auto
r1#sh ip int brie
Interface IP-Address OK? Method Status Prol
FastEthernet0/0 10.1.100.1 YES manual up up
Serial0/0 unassigned YES manual administratively down dow
Loopback1 10.1.1.1 YES manual up up
r1#
r1#ping 10.1.100.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.100.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms
r1#ping 10.1.100.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.100.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms
r1#
r1(config)#router eigrp 1
r1(config-router)#netw 10.0.0.0
r1(config-router)#no auto-summ
r1(config-router)#end
r1#
Jul 21 14:40:21.091: %SYS-5-CONFIG_I: Configured from console by vty0 (10.1.100)
r1#un all
All possible debugging has been turned off
r1#debug eigrp packet
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, )
r1#
Jul 21 14:40:40.423: EIGRP: Sending HELLO on Loopback1
Jul 21 14:40:40.423: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
Jul 21 14:40:40.423: EIGRP: Received HELLO on Loopback1 nbr 10.1.1.1
Jul 21 14:40:40.423: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
Jul 21 14:40:40.427: EIGRP: Packet from ourselves ignored
Jul 21 14:40:41.527: EIGRP: Sending HELLO on FastEthernet0/0
r1(config-router)#netw 10.0.0.0
r1(config-router)#no auto-summ
r1(config-router)#end
r1#
Jul 21 14:40:21.091: %SYS-5-CONFIG_I: Configured from console by vty0 (10.1.100)
r1#un all
All possible debugging has been turned off
r1#debug eigrp packet
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, )
r1#
Jul 21 14:40:40.423: EIGRP: Sending HELLO on Loopback1
Jul 21 14:40:40.423: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
Jul 21 14:40:40.423: EIGRP: Received HELLO on Loopback1 nbr 10.1.1.1
Jul 21 14:40:40.423: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
Jul 21 14:40:40.427: EIGRP: Packet from ourselves ignored
Jul 21 14:40:41.527: EIGRP: Sending HELLO on FastEthernet0/0
onto r2
r2#term mon
r2#debug eigrp packet
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, )
r2#config t
Enter configuration commands, one per line. End with CNTL/Z.
r2(config)#router eigrp 1
r2(config-router)#netw 10.0.0.0
r2(config-router)#
*Jul 21 18:34:50.399: EIGRP: Sending HELLO on FastEthernet0/0
*Jul 21 18:34:50.399: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Jul 21 18:34:50.399: EIGRP: Sending HELLO on Loopback2
*Jul 21 18:34:50.403: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Jul 21 18:34:50.403: EIGRP: Received HELLO on Loopback2 nbr 10.1.2.1
*Jul 21 18:34:50.403: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
*Jul 21 18:34:50.403: EIGRP: Packet from ourselves ignored
*Jul 21 18:34:50.407: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.1.100.1
r2#debug eigrp packet
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, )
r2#config t
Enter configuration commands, one per line. End with CNTL/Z.
r2(config)#router eigrp 1
r2(config-router)#netw 10.0.0.0
r2(config-router)#
*Jul 21 18:34:50.399: EIGRP: Sending HELLO on FastEthernet0/0
*Jul 21 18:34:50.399: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Jul 21 18:34:50.399: EIGRP: Sending HELLO on Loopback2
*Jul 21 18:34:50.403: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Jul 21 18:34:50.403: EIGRP: Received HELLO on Loopback2 nbr 10.1.2.1
*Jul 21 18:34:50.403: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
*Jul 21 18:34:50.403: EIGRP: Packet from ourselves ignored
*Jul 21 18:34:50.407: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.1.100.1
the excitement is driving me out of my tits...
here's the thing... you spend 50 bucks on the book plus shipping and you know damn well it's gonna start in beginners and it's going to be painful at first but the question you have to ask yourself is, "are you that good that you can afford to skip a single page, just in case?"
you bet your ass you're not...
suffer...
r3#config t
Enter configuration commands, one per line. End with CNTL/Z.
r3(config)#router eigrp 1
r3(config-router)#net 10.0.0.0
r3(config-router)#
Jul 21 15:00:56.067: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.3 (Fas
Enter configuration commands, one per line. End with CNTL/Z.
r3(config)#router eigrp 1
r3(config-router)#net 10.0.0.0
r3(config-router)#
Jul 21 15:00:56.067: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.3 (Fas
the point...
r1#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.100.3 Fa0/0 13 00:00:38 3 200 0 6
0 10.1.100.2 Fa0/0 13 00:13:13 9 200 0 7
r1#
the method to the madness... the H stands for handle and lists the order from 0
in which peering sessions have been established... this is an internal number used by eigrp to refer to a neighbor...
behold:
r3#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.100.2 Fa0/0 11 00:07:01 1020 5000 0 7
0 10.1.100.1 Fa0/0 14 00:07:01 5 200 0 6
r3#
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.100.2 Fa0/0 11 00:07:01 1020 5000 0 7
0 10.1.100.1 Fa0/0 14 00:07:01 5 200 0 6
r3#
the payoff...
r1#sh ip eigrp topo
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.1.3.0/24, 1 successors, FD is 156160
via 10.1.100.3 (156160/128256), FastEthernet0/0
P 10.1.2.0/24, 1 successors, FD is 156160
via 10.1.100.2 (156160/128256), FastEthernet0/0
P 10.1.1.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 10.1.100.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
r1#sh ip route eigrp
10.0.0.0/24 is subnetted, 4 subnets
D 10.1.3.0 [90/156160] via 10.1.100.3, 00:16:10, FastEthernet0/0
D 10.1.2.0 [90/156160] via 10.1.100.2, 00:28:44, FastEthernet0/0
r1#ping 10.1.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r1#
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.1.3.0/24, 1 successors, FD is 156160
via 10.1.100.3 (156160/128256), FastEthernet0/0
P 10.1.2.0/24, 1 successors, FD is 156160
via 10.1.100.2 (156160/128256), FastEthernet0/0
P 10.1.1.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 10.1.100.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
r1#sh ip route eigrp
10.0.0.0/24 is subnetted, 4 subnets
D 10.1.3.0 [90/156160] via 10.1.100.3, 00:16:10, FastEthernet0/0
D 10.1.2.0 [90/156160] via 10.1.100.2, 00:28:44, FastEthernet0/0
r1#ping 10.1.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r1#
the output is exactly the same as the manual...
No comments:
Post a Comment