Pages

network cisco ccna gns3 certification arteq

network cisco ccna gns3 certification arteq
a network runs through it

Search insearchofthecert

Sunday, August 19, 2012

the tcl from hell...


foreach address {
172.16.1.1
192.168.48.1
192.168.49.1
192.168.50.1
192.168.51.1
192.168.70.1
172.16.12.1
172.16.2.1
172.16.100.1
172.16.12.2
172.16.23.2
172.16.3.1
192.168.20.1
192.168.25.1
192.168.30.1
192.168.35.1
192.168.40.1
192.168.8.1
192.168.9.1
192.168.10.1
192.168.11.1
172.16.23.3
} { ping $address }

it actually worked... after i closed gns3 last night and got up this morning... and after only two cups of coffee, and no troubleshooting...

+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.48.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.49.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.51.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.70.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.25.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.35.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.40.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.8.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
r1(tcl)#

why wasn't gns3 around in the 2000's... what a game changer...

it's what's for breakfast...

filtering with route maps... if you are starting with switch like i did, pay particular attention to vlan access-maps... i read a number of times that getting vlan access-maps in switch would save you some labor come route time...
here is a link for a tutorial i did on that back in july...

http://insearchofthecert.blogspot.com/2012/07/vlan-access-map.html

and yes they were right...

make two permit acl's for networks 25 and 30 on r2

access-list 1 permit 192.168.25.0
access-list 1 permit 192.168.30.0

starts with permitting traffic, then on to manipulation...

route-map deny_this deny 10
match ip address 1
route-map deny_this permit 20

the route-map defines the variable deny_this to deny or permit traffic that matches acl 1...
10 is merely a counter (sequence number) just like 20...
the next route-map permits all other traffic...

you could make it 5 and 7... just keep them numerically ordered...

r2#sh access-list
Standard IP access list 1
    10 permit 192.168.25.0
    20 permit 192.168.30.0
r2#sh route-map
route-map deny_this, deny, sequence 5
  Match clauses:
    ip address (access-lists): 1
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
route-map deny_this, permit, sequence 7
  Match clauses:
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes

now you'll need to adjust your redistribute statement to include the map...

r2#sh run | begin eigrp                   
router eigrp 1
 network 172.16.0.0
 redistribute ospf 1 metric 1 1 0 1 1500
 passive-interface Serial1/2
!

since we are taking from ospf, to eigrp, we need only be concerned with the eigrp redistribute statement... also, since our metrics for eigrp are already defined, we only need include the route-map to the redistribute statement... thus...

r2(config)#router eigrp 1
r2(config-router)#redistribute ospf 1 route-map deny_this
r2(config-router)#end
r2#
*Aug 19 06:55:12: %SYS-5-CONFIG_I: Configured from console by console
r2#sh run | begin eigrp
router eigrp 1
network 172.16.0.0
redistribute ospf 1 metric 1 1 0 1 1500 route-map deny_this
passive-interface Serial1/2

r1#sh ip route eigrp

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
D        172.16.2.0/24 [90/40640000] via 172.16.12.2, 00:09:14, Serial1/0
D EX     172.16.3.0/24 [170/2560512256] via 172.16.12.2, 00:09:04, Serial1/0
D        172.16.23.0/24 [90/41024000] via 172.16.12.2, 00:09:14, Serial1/0
D        172.16.100.0/24 [90/40640000] via 172.16.12.2, 00:09:14, Serial1/0
D EX  192.168.8.0/22 [170/2560512256] via 172.16.12.2, 00:09:04, Serial1/0
D EX  192.168.20.0/24 [170/2560512256] via 172.16.12.2, 00:09:04, Serial1/0
D EX  192.168.25.0/24 [170/2560512256] via 172.16.12.2, 00:09:04, Serial1/0
D EX  192.168.30.0/24 [170/2560512256] via 172.16.12.2, 00:09:04, Serial1/0
      192.168.35.0/32 is subnetted, 1 subnets
D EX     192.168.35.1 [170/2560512256] via 172.16.12.2, 00:09:04, Serial1/0
D EX  192.168.40.0/24 [170/2560512256] via 172.16.12.2, 00:09:04, Serial1/0
D     192.168.48.0/23 is a summary, 00:09:15, Null0
r1#sh ip route eigrp

Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
D        172.16.2.0/24 [90/40640000] via 172.16.12.2, 00:42:58, Serial1/0
D EX     172.16.3.0/24 [170/2560512256] via 172.16.12.2, 00:42:48, Serial1/0
D        172.16.23.0/24 [90/41024000] via 172.16.12.2, 00:42:58, Serial1/0
D        172.16.100.0/24 [90/40640000] via 172.16.12.2, 00:42:58, Serial1/0
D EX  192.168.8.0/22 [170/2560512256] via 172.16.12.2, 00:42:48, Serial1/0
D EX  192.168.20.0/24 [170/2560512256] via 172.16.12.2, 00:42:48, Serial1/0
      192.168.35.0/32 is subnetted, 1 subnets
D EX     192.168.35.1 [170/2560512256] via 172.16.12.2, 00:42:48, Serial1/0
D EX  192.168.40.0/24 [170/2560512256] via 172.16.12.2, 00:42:48, Serial1/0
D     192.168.48.0/23 is a summary, 00:42:59, Null0
r1#ping 192.168.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

all gone...


No comments:

Post a Comment