http://ardenpackeer.com/tutorials/routeswitch/tutorial-ospf-network-types-and-frame-relay-part-1/
earlier in the week i wrote something about not elaborating on arden's stuff... i'm taking that back because this is my site and i can do take backs if i want, and you can always go somewhere else...
simple topology, complicated stuff...
the default timers for ospf on ethernet are 10, 40 and slower links (aka serial) 30, 120...
r2#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
Internet Address 192.168.1.2/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
Topology-MTID Cost Disabled Shutdown Topology Name
0 64 no no Base
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
for us humans that means four times the hello interval... the fact is that cisco uses 30, 120 for all non-broadcast networks no matter the media, which we will see in a minute...
r1#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/DROTHER 00:01:48 192.168.1.2 Serial1/0
3.3.3.3 0 FULL/DROTHER 00:01:59 192.168.1.3 Serial1/0
note that the spokes are neither dr/bdr by design, meaning that the ospf priority has been manually set to 0 to avoid any election confusion...
r2#sh run int s1/0
Building configuration...
Current configuration : 267 bytes
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 192.168.1.1 201
frame-relay map ip 192.168.1.3 201
no frame-relay inverse-arp
and the neighbor statements are used because it is non-broadcast, and the hub needs to use unicast to send it's shit out...
r1#sh run | sec router
router ospf 1
router-id 1.1.1.1
network 0.0.0.0 255.255.255.255 area 0
neighbor 192.168.1.2
neighbor 192.168.1.3
r1#sh run int s1/0router ospf 1
router-id 1.1.1.1
network 0.0.0.0 255.255.255.255 area 0
neighbor 192.168.1.2
neighbor 192.168.1.3
Building configuration...
Current configuration : 247 bytes
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.3 103
frame-relay map ip 192.168.1.2 102
no frame-relay inverse-arp
to make a frame topology behave like a broadcast type, or the default broadcast type which is ethernet, frame has to be manipulated to broadcast...of course that sounds obvious...
since we want frame to support the broadcast type, eliminate the ospf neighbor statements and change the type to broadcast...
r1(config)#int s1/0
r1(config-if)#ip ospf netw broad
r1(config-if)#
*Nov 17 06:16:33.627: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial1/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Nov 17 06:16:33.631: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial1/0 from FULL to DOWN, Neighbor Down: Interface down or detached
r1#sh run | sec router
router ospf 1
router-id 1.1.1.1
network 0.0.0.0 255.255.255.255 area 0
r1#sh run int s1/0
Building configuration...
Current configuration : 263 bytes
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.3 103 broadcast
frame-relay map ip 192.168.1.2 102 broadcast
no frame-relay inverse-arp
r2#sh run int s1/0
Building configuration...
Current configuration : 273 bytes
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 192.168.1.1 201 broadcast
frame-relay map ip 192.168.1.3 201
no frame-relay inverse-arp
note that the broadcast only has to be enabled on each router's map to the hub... (this avoids unnecessary multicasts)
r3#sh run int s1/0
Building configuration...
Current configuration : 273 bytes
!
interface Serial1/0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 192.168.1.1 301 broadcast
frame-relay map ip 192.168.1.2 301
no frame-relay inverse-arp
and of course the priority remains 0, so there is no confusion in the election...
here is the upshot...
r1#sh ip ospf int
Serial1/0 is up, line protocol is up
Internet Address 192.168.1.1/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 64
Topology-MTID Cost Disabled Shutdown Topology Name
0 64 no no Base
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit
all of this is perfectly meaningless because arden explained it much better than me but i now feel better taking the time to prove it for myself, thus driving the salient points home... so there...
and finally, arden's summation:
- Non-Broadcast network type is the default on a physical serial interface with ospf configured
- Non-Broadcast networks send unicast packets, so must be configured with neighbor statements
- Non-Broadcast networks have Hello and Dead intervals of 30 seconds and 120 seconds respectively
- Broadcast network types is the default on an ethernet interface.
- Broadcast network types must support broadcasting capability on a layer 2 topology
- Non-Broadcast and Broadcast network types require a DR. Care should be taken in DR placement (should be the Hub).
No comments:
Post a Comment