ping em all...
r1(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#10.1.100.1
+>(tcl)#10.1.100.2
+>(tcl)#10.1.200.1
+>(tcl)#10.1.200.2
+>(tcl)#10.1.200.3
+>(tcl)#} {
+>(tcl)#ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
r1(tcl)#tclquit
change the cost of f0/0...
r1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 5 subnets
O 10.1.3.0 [110/2] via 10.1.200.3, 22:42:05, FastEthernet0/0
O 10.1.2.0 [110/2] via 10.1.200.2, 22:42:05, FastEthernet0/0
C 10.1.1.0 is directly connected, Loopback1
C 10.1.100.0 is directly connected, Serial0/0
C 10.1.200.0 is directly connected, FastEthernet0/0
r1#config t
Enter configuration commands, one per line. End with CNTL/Z.
r1(config)#int f0/0
r1(config-if)#ip ospf cost 50
r1(config-if)#end
r1#sh i
Jul 31 17:13:18: %SYS-5-CONFIG_I: Configured from console by console
r1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 5 subnets
O 10.1.3.0 [110/51] via 10.1.200.3, 00:00:19, FastEthernet0/0
O 10.1.2.0 [110/51] via 10.1.200.2, 00:00:19, FastEthernet0/0
C 10.1.1.0 is directly connected, Loopback1
C 10.1.100.0 is directly connected, Serial0/0
C 10.1.200.0 is directly connected, FastEthernet0/0
r1#
Tuesday, July 31, 2012
ospf lab 1 cont...
Monday, July 30, 2012
loopbacks...
add the loopbacks, then the network statement
netw 10.1.x.0 0.0.0.255 area 0 in router config mode
this is incorrect... loopbacks should be configured as host routes... note below
r2(config-if)#do sh ip ospf int lo2
Loopback2 is up, line protocol is up
Internet Address 10.1.2.1/24, Area 0
Process ID 1, Router ID 10.1.2.1, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
Loopback2 is up, line protocol is up
Internet Address 10.1.2.1/24, Area 0
Process ID 1, Router ID 10.1.2.1, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
r2(config-if)#ip ospf netw point-to-p
r2(config-if)#do sh ip ospf int lo2
Loopback2 is up, line protocol is up
Internet Address 10.1.2.1/24, Area 0
Process ID 1, Router ID 10.1.2.1, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
r2(config-if)#
r2(config-if)#do sh ip ospf int lo2
Loopback2 is up, line protocol is up
Internet Address 10.1.2.1/24, Area 0
Process ID 1, Router ID 10.1.2.1, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
r2(config-if)#
or simply configure them as host routes in the first place...
intra v inter...
intra means inside or within
inter means between or among
from stretch at
http://packetlife.net/blog/2010/feb/10/ospf-filtering-inter-area-vs-intra-area/
There are two points at which OSPF routes can be filtered: within an area, or between areas on an area border router (ABR).
intra inter
from:
http://users.lmi.net/canepa/subdir/ospf_fundamentals.html
inter means between or among
from stretch at
http://packetlife.net/blog/2010/feb/10/ospf-filtering-inter-area-vs-intra-area/
There are two points at which OSPF routes can be filtered: within an area, or between areas on an area border router (ABR).
intra inter
from:
http://users.lmi.net/canepa/subdir/ospf_fundamentals.html
OSPF Router Types
Internal Router: Responsible for maintaining a
current and accurate database of subnets within the area. Forwards
data to other networks using the shortest path.
Backbone Router: Has an interface connected to the
backbone (Area 0).
Area Border Router (ABR): Has interfaces in multiple
areas with at lest one interface in area 0. Connects
other areas to the backbone and maintains
routing information for each connected area.
Autonomous System Boundary Router (ASBR): Router
located between OSPF autonomous system and a non-OSPF network. Used to redistribute routing information between networks. Must reside in a non-stub area. Also, a router becomes an
ASBR when OSPF is redistributing from other routing protocols, including static
routes, and it may reside in a pure OSPF network.
OSPF LSA Types
Type 1: Router link advertisements
generated by each router for each area it belongs to. Flooded
to a single area only (intra-area route).
In a multiarea OSPF network, routes, originated
within an area, are known by the routers in the same area as Intra-Area routes.
These routes are flagged as O in the
“show
ip route” command output.
Type 2: Network link advertisements generated by
designated routers describing the set of routers attached to a particular
network. Flooded to the area that contains the network (intra-area route). When a route crosses an OSPF Area Border Router
(ABR), the route is known as an OSPF Inter-Area route. These routes are flagged
as O IA in the “show ip
route” command output.
Both Intra and Inter-Area
routes are also called OSPF Internal
routes, as they are generated by OSPF itself, when an interface is covered
with the OSPF network command.
Type 3/4: Summary link
advertisements generated by ABRs describing inter-area routes. Type 3
describes routes to networks and is used for summarization. The "default-information originate"
is also Type 3. Type 4 describes routes to the ASBR (interarea summary route).
Type 5: Generated by the ASBR and describes links
external to the Autonomous System (AS). These are the redistributed (from other
routing protocols including static routes) routes. Flooded to
all areas except stub areas (external
route). Routes which were redistributed into OSPF, such as Connected, Static, or other Routing
Protocol, are known as External
Type-2 or External Type-1. These
routes are flagged as O E2 or O E1 in the “show ip route” command output.
Type 6: Group membership link entry generated by
multicast OSPF routers.
Type 7: NSSA external routes
generated by ASBR. Only flooded to the NSSA.
External routes injected internally by ASBRs within each POP (Areas other than
Area 0) are LSAs of type 7. The ABR between will translate LASs type 7 to LSAs
type 5 from each POP/Area to Area 0 (external
route). When an area is configured as a Not-So-Stub Area (NSSA), and routes
are redistributed into OSPF, the routes are known as NSSA external type 2 or NSSA
external type 1. These routes are flagged as O N2 or O N1 in the “how
ip route” command output.
Sunday, July 29, 2012
ospf lab 1...
finally...
it's very pretty... it says ospf right on it...
i know you're very excited...
r1
int lo1
desc engineering
ip add 10.1.1.1 255.255.255.0
int f0/0
ip add 10.1.200.1 255.255.255.0
no shut
r2
int lo2
desc meatmarketing
ip add 10.1.2.1 255.255.255.0
int f0/0
ip add 10.1.200.2 255.255.255.0
no shut
r3
int lo3
desc asscounting
10.1.3.1 255.255.255.0
int f0/0
ip add 10.1.200.3 255.255.255.0
no shut
light em up...
r2#ping 10.1.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/18/36 ms
r2#ping 10.1.200.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/11/28 ms
r2#
do up the serials...
r1
int s0/0
ip add 10.1.100.1 255.255.255.0
clockra 64000
band 64
no shut
r2
int s0/0
ip add 10.1.100.2 255.255.255.0
band 64
no shut
match the bandwidth and the clock rate...
r2(config-if)#
Jul 29 18:47:53: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
r2(config-if)#
Jul 29 18:47:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
r2(config-if)#
for a quick review on wild card masks go here... or don't...
http://insearchofthecert.blogspot.com/2011/12/wildassmasks.html
r3#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 10.1.200.3/24, Area 0
Process ID 1, Router ID 10.1.200.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 10.1.1.1, Interface address 10.1.200.1
Backup Designated router (ID) 10.1.200.3, Interface address 10.1.200.3
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 10.1.1.1 (Designated Router)
Adjacent with neighbor 10.1.2.1
Suppress hello for 0 neighbor(s)
r3#sh ip ospf int brie
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 0 10.1.200.3/24 1 BDR 2/2
r3#sh ip ospf data
OSPF Router with ID (10.1.200.3) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 557 0x80000004 0x00011F 3
10.1.2.1 10.1.2.1 536 0x80000004 0x00021B 3
10.1.200.3 10.1.200.3 634 0x80000002 0x00E8EF 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.200.1 10.1.1.1 540 0x80000002 0x00332E
r3#
it's very pretty... it says ospf right on it...
i know you're very excited...
r1
int lo1
desc engineering
ip add 10.1.1.1 255.255.255.0
int f0/0
ip add 10.1.200.1 255.255.255.0
no shut
r2
int lo2
desc meatmarketing
ip add 10.1.2.1 255.255.255.0
int f0/0
ip add 10.1.200.2 255.255.255.0
no shut
r3
int lo3
desc asscounting
10.1.3.1 255.255.255.0
int f0/0
ip add 10.1.200.3 255.255.255.0
no shut
light em up...
r2#ping 10.1.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/18/36 ms
r2#ping 10.1.200.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/11/28 ms
r2#
do up the serials...
r1
int s0/0
ip add 10.1.100.1 255.255.255.0
clockra 64000
band 64
no shut
r2
int s0/0
ip add 10.1.100.2 255.255.255.0
band 64
no shut
match the bandwidth and the clock rate...
r2(config-if)#
Jul 29 18:47:53: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
r2(config-if)#
Jul 29 18:47:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
r2(config-if)#
for a quick review on wild card masks go here... or don't...
http://insearchofthecert.blogspot.com/2011/12/wildassmasks.html
r1#sh run | begin router
router ospf 1
log-adjacency-changes
network 10.1.100.0 0.0.0.255 area 0
network 10.1.200.0 0.0.0.255 area 0
router ospf 1
log-adjacency-changes
network 10.1.100.0 0.0.0.255 area 0
network 10.1.200.0 0.0.0.255 area 0
r3#sh run | begin router
router ospf 1
log-adjacency-changes
network 10.1.200.0 0.0.0.255 area 0
r1#debug ip ospf adj
OSPF adjacency events debugging is on
r1#
Jul 29 19:02:21: OSPF: Rcv DBD from 10.1.2.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x7 len 32 mtu 1500 state INIT
Jul 29 19:02:21: OSPF: 2 Way Communication to 10.1.2.1 on Serial0/0, state 2WAY
Jul 29 19:02:21: OSPF: Send DBD to 10.1.2.1 on Serial0/0 seq 0x2337 opt 0x52 flag 0x7 len 32
Jul 29 19:02:21: OSPF: NBR Negotiation Done. We are the SLAVE
Jul 29 19:02:21: OSPF: Send DBD to 10.1.2.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x2 len 92
Jul 29 19:02:21: OSPF: Rcv DBD from 10.1.2.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x3 len 52 mtu 1500 state EXCHANGE
Jul 29 19:02:21: OSPF: Send DBD to 10.1.2.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x0 len 32
Jul 29 19:02:21: OSPF: Database request to 10.1.2.1
Jul 29 19:02:21: OSPF: sent LS REQ packet to 10.1.100.2, length 12
Jul 29 19:02:21: OSPF: Rcv DBD from 10.1.2.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x1 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:21: OSPF: Exchange Done with 10.1.2.1 on Serial0/0
Jul 29 19:02:21: OSPF: Send
r1#DBD to 10.1.2.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x0 len 32
Jul 29 19:02:21: OSPF: Synchronized with 10.1.2.1 on Serial0/0, state FULL
Jul 29 19:02:21: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0 from LOADING to FULL, Loading Done
r1#
Jul 29 19:02:21: OSPF: Build router LSA for area 0, router ID 10.1.1.1, seq 0x80000004, process 1
r1#
Jul 29 19:02:38: OSPF: Rcv DBD from 10.1.2.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x7 len 32 mtu 1500 state INIT
Jul 29 19:02:38: OSPF: 2 Way Communication to 10.1.2.1 on FastEthernet0/0, state 2WAY
Jul 29 19:02:38: OSPF: Neighbor change Event on interface FastEthernet0/0
Jul 29 19:02:38: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:38: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:38: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:38: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x136B opt 0x52 flag 0x7 len 32
Jul 29 19:02:38: OSPF: NBR Negotiation Done. We are the SLAVE
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x2 len 112
Jul 29 19:02:38: OSPF: Rcv DBD from 10.1.2.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x3 len 112 mtu 1500 state EXCHANGE
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x0 len 32
Jul 29 19
r1#:02:38: OSPF: Rcv DBD from 10.1.2.1 on FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x1 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:38: OSPF: Exchange Done with 10.1.2.1 on FastEthernet0/0
Jul 29 19:02:38: OSPF: Synchronized with 10.1.2.1 on FastEthernet0/0, state FULL
Jul 29 19:02:38: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x0 len 32
Jul 29 19:02:39: OSPF: Build network LSA for FastEthernet0/0, router ID 10.1.1.1
Jul 29 19:02:39: OSPF: Build network LSA for FastEthernet0/0, router ID 10.1.1.1
r1#
Jul 29 19:02:47: OSPF: Neighbor change Event on interface FastEthernet0/0
Jul 29 19:02:47: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:47: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:47: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:47: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
Jul 29 19:02:47: OSPF: Neighbor change Event on interface FastEthernet0/0
Jul 29 19:02:47: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:47: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:47: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:47: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
router ospf 1
log-adjacency-changes
network 10.1.200.0 0.0.0.255 area 0
r1#debug ip ospf adj
OSPF adjacency events debugging is on
r1#
Jul 29 19:02:21: OSPF: Rcv DBD from 10.1.2.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x7 len 32 mtu 1500 state INIT
Jul 29 19:02:21: OSPF: 2 Way Communication to 10.1.2.1 on Serial0/0, state 2WAY
Jul 29 19:02:21: OSPF: Send DBD to 10.1.2.1 on Serial0/0 seq 0x2337 opt 0x52 flag 0x7 len 32
Jul 29 19:02:21: OSPF: NBR Negotiation Done. We are the SLAVE
Jul 29 19:02:21: OSPF: Send DBD to 10.1.2.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x2 len 92
Jul 29 19:02:21: OSPF: Rcv DBD from 10.1.2.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x3 len 52 mtu 1500 state EXCHANGE
Jul 29 19:02:21: OSPF: Send DBD to 10.1.2.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x0 len 32
Jul 29 19:02:21: OSPF: Database request to 10.1.2.1
Jul 29 19:02:21: OSPF: sent LS REQ packet to 10.1.100.2, length 12
Jul 29 19:02:21: OSPF: Rcv DBD from 10.1.2.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x1 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:21: OSPF: Exchange Done with 10.1.2.1 on Serial0/0
Jul 29 19:02:21: OSPF: Send
r1#DBD to 10.1.2.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x0 len 32
Jul 29 19:02:21: OSPF: Synchronized with 10.1.2.1 on Serial0/0, state FULL
Jul 29 19:02:21: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial0/0 from LOADING to FULL, Loading Done
r1#
Jul 29 19:02:21: OSPF: Build router LSA for area 0, router ID 10.1.1.1, seq 0x80000004, process 1
r1#
Jul 29 19:02:38: OSPF: Rcv DBD from 10.1.2.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x7 len 32 mtu 1500 state INIT
Jul 29 19:02:38: OSPF: 2 Way Communication to 10.1.2.1 on FastEthernet0/0, state 2WAY
Jul 29 19:02:38: OSPF: Neighbor change Event on interface FastEthernet0/0
Jul 29 19:02:38: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:38: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:38: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:38: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x136B opt 0x52 flag 0x7 len 32
Jul 29 19:02:38: OSPF: NBR Negotiation Done. We are the SLAVE
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x2 len 112
Jul 29 19:02:38: OSPF: Rcv DBD from 10.1.2.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x3 len 112 mtu 1500 state EXCHANGE
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x0 len 32
Jul 29 19
r1#:02:38: OSPF: Rcv DBD from 10.1.2.1 on FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x1 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:38: OSPF: Exchange Done with 10.1.2.1 on FastEthernet0/0
Jul 29 19:02:38: OSPF: Synchronized with 10.1.2.1 on FastEthernet0/0, state FULL
Jul 29 19:02:38: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Jul 29 19:02:38: OSPF: Send DBD to 10.1.2.1 on FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x0 len 32
Jul 29 19:02:39: OSPF: Build network LSA for FastEthernet0/0, router ID 10.1.1.1
Jul 29 19:02:39: OSPF: Build network LSA for FastEthernet0/0, router ID 10.1.1.1
r1#
Jul 29 19:02:47: OSPF: Neighbor change Event on interface FastEthernet0/0
Jul 29 19:02:47: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:47: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:47: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:47: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
Jul 29 19:02:47: OSPF: Neighbor change Event on interface FastEthernet0/0
Jul 29 19:02:47: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:47: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:47: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:47: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
r2#debug ip ospf adj
OSPF adjacency events debugging is on
r2#config t
Enter configuration commands, one per line. End with CNTL/Z.
r2(config)#router ospf 1
r2(config-router)#netw 10.1.100.0 0.0.0.255 area 0
r2(config-router)#
Jul 29 19:02:10: OSPF: Interface Serial0/0 going Up
Jul 29 19:02:11: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000001, process 1
Jul 29 19:02:11: OSPF: 2 Way Communication to 10.1.1.1 on Serial0/0, state 2WAY
Jul 29 19:02:11: OSPF: Send DBD to 10.1.1.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x7 len 32
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x2337 opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
Jul 29 19:02:11: OSPF: First DBD and we are not SLAVE
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x2 len 92 mtu 1500 state EXSTART
Jul 29 19:02:11: OSPF: NBR Negotiation Done. We are the MASTER
Jul 29 19:02:11: OSPF: Send DBD to 10.1.1.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x3 len 52
Jul 29 19:02:11: OSPF: Database request to 10.1.1.1
Jul 29 19:02:11: OSPF: sent LS REQ packet to 10.1.100.1, length 36
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x0 len 32 mt
r2(config-router)#netw u 1500 state EXCHANGE
Jul 29 19:02:11: OSPF: Send DBD to 10.1.1.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x1 len 32
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:11: OSPF: Exchange Done with 10.1.1.1 on Serial0/0
Jul 29 19:02:11: OSPF: Synchronized with 10.1.1.1 on Serial0/0, state FULL
Jul 29 19:02:11: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0 from LOADING to FULL, Loading Done
r2(config-router)#netw 10.1.
Jul 29 19:02:16: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000002, process 1
r2(config-router)#netw 10.1.200.0 0.0.0.255 area 0
r2(config-router)#
Jul 29 19:02:27: OSPF: Interface FastEthernet0/0 going Up
Jul 29 19:02:28: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000003, process 1
Jul 29 19:02:28: OSPF: 2 Way Communication to 10.1.1.1 on FastEthernet0/0, state 2WAY
Jul 29 19:02:28: OSPF: 2 Way Communication to 10.1.200.3 on FastEthernet0/0, state 2WAY
Jul 29 19:02:28: OSPF: Backup seen Event before WAIT timer on FastEthernet0/0
Jul 29 19:02:28: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:28: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:28: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:28: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
Jul 29 19:02:28: OSPF: Send DBD to 10.1.1.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x7 len 32
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x1593 opt 0x52 flag 0x7 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.200.3 on FastEthernet0/0 seq 0x2647 opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
Jul 29 19:02:28: OSPF: NBR Negotiation Don
r2(config-router)#e. We are the SLAVE
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x2647 opt 0x52 flag 0x2 len 112
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x136B opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
Jul 29 19:02:28: OSPF: First DBD and we are not SLAVE
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x2 len 112 mtu 1500 state EXSTART
Jul 29 19:02:28: OSPF: NBR Negotiation Done. We are the MASTER
Jul 29 19:02:28: OSPF: Send DBD to 10.1.1.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x3 len 112
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.200.3 on FastEthernet0/0 seq 0x2648 opt 0x52 flag 0x3 len 112 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x2648 opt 0x52 flag 0x0 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Send DBD to 10.1.1.1 on
r2(config-router)#FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x1 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.200.3 on FastEthernet0/0 seq 0x2649 opt 0x52 flag 0x1 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Exchange Done with 10.1.200.3 on FastEthernet0/0
Jul 29 19:02:28: OSPF: Synchronized with 10.1.200.3 on FastEthernet0/0, state FULL
Jul 29 19:02:28: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.200.3 on FastEthernet0/0 from LOADING to FULL, Loading Done
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x2649 opt 0x52 flag 0x0 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Exchange Done with 10.1.1.1 on FastEthernet0/0
Jul 29 19:02:28: OSPF: Synchronized with 10.1.1.1 on FastEthernet0/0, state FULL
Jul 29 19:02:28: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
r2(config-router)#
Jul 29 19:02:33: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000004, process 1
r2(config-router)#
OSPF adjacency events debugging is on
r2#config t
Enter configuration commands, one per line. End with CNTL/Z.
r2(config)#router ospf 1
r2(config-router)#netw 10.1.100.0 0.0.0.255 area 0
r2(config-router)#
Jul 29 19:02:10: OSPF: Interface Serial0/0 going Up
Jul 29 19:02:11: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000001, process 1
Jul 29 19:02:11: OSPF: 2 Way Communication to 10.1.1.1 on Serial0/0, state 2WAY
Jul 29 19:02:11: OSPF: Send DBD to 10.1.1.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x7 len 32
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x2337 opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
Jul 29 19:02:11: OSPF: First DBD and we are not SLAVE
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x1F10 opt 0x52 flag 0x2 len 92 mtu 1500 state EXSTART
Jul 29 19:02:11: OSPF: NBR Negotiation Done. We are the MASTER
Jul 29 19:02:11: OSPF: Send DBD to 10.1.1.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x3 len 52
Jul 29 19:02:11: OSPF: Database request to 10.1.1.1
Jul 29 19:02:11: OSPF: sent LS REQ packet to 10.1.100.1, length 36
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x1F11 opt 0x52 flag 0x0 len 32 mt
r2(config-router)#netw u 1500 state EXCHANGE
Jul 29 19:02:11: OSPF: Send DBD to 10.1.1.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x1 len 32
Jul 29 19:02:11: OSPF: Rcv DBD from 10.1.1.1 on Serial0/0 seq 0x1F12 opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:11: OSPF: Exchange Done with 10.1.1.1 on Serial0/0
Jul 29 19:02:11: OSPF: Synchronized with 10.1.1.1 on Serial0/0, state FULL
Jul 29 19:02:11: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0 from LOADING to FULL, Loading Done
r2(config-router)#netw 10.1.
Jul 29 19:02:16: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000002, process 1
r2(config-router)#netw 10.1.200.0 0.0.0.255 area 0
r2(config-router)#
Jul 29 19:02:27: OSPF: Interface FastEthernet0/0 going Up
Jul 29 19:02:28: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000003, process 1
Jul 29 19:02:28: OSPF: 2 Way Communication to 10.1.1.1 on FastEthernet0/0, state 2WAY
Jul 29 19:02:28: OSPF: 2 Way Communication to 10.1.200.3 on FastEthernet0/0, state 2WAY
Jul 29 19:02:28: OSPF: Backup seen Event before WAIT timer on FastEthernet0/0
Jul 29 19:02:28: OSPF: DR/BDR election on FastEthernet0/0
Jul 29 19:02:28: OSPF: Elect BDR 10.1.200.3
Jul 29 19:02:28: OSPF: Elect DR 10.1.1.1
Jul 29 19:02:28: DR: 10.1.1.1 (Id) BDR: 10.1.200.3 (Id)
Jul 29 19:02:28: OSPF: Send DBD to 10.1.1.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x7 len 32
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x1593 opt 0x52 flag 0x7 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.200.3 on FastEthernet0/0 seq 0x2647 opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
Jul 29 19:02:28: OSPF: NBR Negotiation Don
r2(config-router)#e. We are the SLAVE
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x2647 opt 0x52 flag 0x2 len 112
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x136B opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
Jul 29 19:02:28: OSPF: First DBD and we are not SLAVE
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x1FF7 opt 0x52 flag 0x2 len 112 mtu 1500 state EXSTART
Jul 29 19:02:28: OSPF: NBR Negotiation Done. We are the MASTER
Jul 29 19:02:28: OSPF: Send DBD to 10.1.1.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x3 len 112
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.200.3 on FastEthernet0/0 seq 0x2648 opt 0x52 flag 0x3 len 112 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x2648 opt 0x52 flag 0x0 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x1FF8 opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Send DBD to 10.1.1.1 on
r2(config-router)#FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x1 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.200.3 on FastEthernet0/0 seq 0x2649 opt 0x52 flag 0x1 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Exchange Done with 10.1.200.3 on FastEthernet0/0
Jul 29 19:02:28: OSPF: Synchronized with 10.1.200.3 on FastEthernet0/0, state FULL
Jul 29 19:02:28: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.200.3 on FastEthernet0/0 from LOADING to FULL, Loading Done
Jul 29 19:02:28: OSPF: Send DBD to 10.1.200.3 on FastEthernet0/0 seq 0x2649 opt 0x52 flag 0x0 len 32
Jul 29 19:02:28: OSPF: Rcv DBD from 10.1.1.1 on FastEthernet0/0 seq 0x1FF9 opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
Jul 29 19:02:28: OSPF: Exchange Done with 10.1.1.1 on FastEthernet0/0
Jul 29 19:02:28: OSPF: Synchronized with 10.1.1.1 on FastEthernet0/0, state FULL
Jul 29 19:02:28: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
r2(config-router)#
Jul 29 19:02:33: OSPF: Build router LSA for area 0, router ID 10.1.2.1, seq 0x80000004, process 1
r2(config-router)#
r1#sh ip proto
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 10.1.1.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.1.100.0 0.0.0.255 area 0
10.1.200.0 0.0.0.255 area 0
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 110)
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 10.1.1.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.1.100.0 0.0.0.255 area 0
10.1.200.0 0.0.0.255 area 0
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 110)
r1#sh ip ospf
Routing Process "ospf 1" with ID 10.1.1.1
Start time: 00:38:18.916, Time elapsed: 00:10:40.500
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:04:46.624 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 4. Checksum Sum 0x011F57
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Routing Process "ospf 1" with ID 10.1.1.1
Start time: 00:38:18.916, Time elapsed: 00:10:40.500
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:04:46.624 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 4. Checksum Sum 0x011F57
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
r2#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 1 FULL/DR 00:00:31 10.1.200.1 FastEthernet0/0
10.1.200.3 1 FULL/BDR 00:00:32 10.1.200.3 FastEthernet0/0
10.1.1.1 0 FULL/ - 00:00:34 10.1.100.1 Serial0/0
r2#
Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 1 FULL/DR 00:00:31 10.1.200.1 FastEthernet0/0
10.1.200.3 1 FULL/BDR 00:00:32 10.1.200.3 FastEthernet0/0
10.1.1.1 0 FULL/ - 00:00:34 10.1.100.1 Serial0/0
r2#
FastEthernet0/0 is up, line protocol is up
Internet Address 10.1.200.3/24, Area 0
Process ID 1, Router ID 10.1.200.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 10.1.1.1, Interface address 10.1.200.1
Backup Designated router (ID) 10.1.200.3, Interface address 10.1.200.3
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 10.1.1.1 (Designated Router)
Adjacent with neighbor 10.1.2.1
Suppress hello for 0 neighbor(s)
r3#sh ip ospf int brie
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 0 10.1.200.3/24 1 BDR 2/2
r3#sh ip ospf data
OSPF Router with ID (10.1.200.3) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 557 0x80000004 0x00011F 3
10.1.2.1 10.1.2.1 536 0x80000004 0x00021B 3
10.1.200.3 10.1.200.3 634 0x80000002 0x00E8EF 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.200.1 10.1.1.1 540 0x80000002 0x00332E
r3#
more eigrp lab 6... done...
r1(config-router)#neighbor 172.16.12.2 s0/0
r1(config-router)#end
r1#
Jul 29 16:39:39: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.12.2 (Serial0/0) is down: Static peer configured
r1#
Jul 29 16:39:40: %SYS-5-CONFIG_I: Configured from console by console
r1#ping 172.16.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/20 ms
r1#
r2(config-if)#ip hello-interval eigrp 1 2
r2(config-if)#end
r2#
Jul 29 16:47:20: %SYS-5-CONFIG_I: Configured from console by console
r2#
r2#sh ip eigrp int det s0/2
IP-EIGRP interfaces for process 1
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/2 1 0/0 19 10/380 464 0
Hello interval is 2 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 15/17
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 3
Retransmissions sent: 0 Out-of-sequence rcvd: 1
Authentication mode is not set
r2#
r4(config)#key chain suck-key
r4(config-keychain)#key 1
r4(config-keychain-key)#key-string suck-key
r4(config-keychain-key)#exit
r4(config-keychain)#exit
r4(config)#int s0/3
r4(config-if)#ip authenti key-chain eigrp 1 suck-key
r4(config-if)#
Jul 29 16:51:50: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.3 (Serial0/3) is down: keychain changed
r4(config-if)#
Jul 29 16:51:51: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.3 (Serial0/3) is up: new adjacency
r4(config-if)#ip authenti mode eigrp 1 md5
r4(config-if)#
Jul 29 16:52:05: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.3 (Serial0/3) is down: authentication mode changed
r4(config-if)#
Jul 29 16:54:07: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.3 (Serial0/3) is up: new adjacency
r4(config-if)#
r3(config)#key chain suck-key
r3(config-keychain)#key 1
r3(config-keychain-key)#key-string suck-key
r3(config-keychain-key)#exit
r3(config-keychain)#exit
r3(config)#int s0/3
r3(config-if)#ip authenti key-chain eigrp 1 suck-key
r3(config-if)#ip authenti mode eigrp 1 md5
r3(config-if)#end
r3#
Jul 29 16:53:35: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.4 (Serial0/3) is up: new adjacency
Jul 29 16:53:35: %SYS-5-CONFIG_I: Configured from console by console
r3#
r3(config-keychain)#key 1
r3(config-keychain-key)#key-string suck-key
r3(config-keychain-key)#exit
r3(config-keychain)#exit
r3(config)#int s0/3
r3(config-if)#ip authenti key-chain eigrp 1 suck-key
r3(config-if)#ip authenti mode eigrp 1 md5
r3(config-if)#end
r3#
Jul 29 16:53:35: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.4 (Serial0/3) is up: new adjacency
Jul 29 16:53:35: %SYS-5-CONFIG_I: Configured from console by console
r3#
r3#sh ip eigrp int det s0/3
IP-EIGRP interfaces for process 1
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/3 1 0/0 19 10/380 464 0
Hello interval is 5 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 14/31
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 9
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "suck-key"
r3#
IP-EIGRP interfaces for process 1
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/3 1 0/0 19 10/380 464 0
Hello interval is 5 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 14/31
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 9
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "suck-key"
r3#
r4#sh ip eigrp int det s0/3
IP-EIGRP interfaces for process 1
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/3 1 0/0 26 10/380 472 0
Hello interval is 5 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 23/26
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 8
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "suck-key"
r4#
and i did the tcl script earlier...
eigrp lab 6 summs...
r3#sh ip route eigrp
172.16.0.0/16 is variably subnetted, 13 subnets, 2 masks
D 172.16.4.32/27 [90/40640000] via 172.16.34.4, 00:00:10, Serial0/3
D 172.16.12.0/24 [90/41024000] via 172.16.23.2, 00:32:17, Serial0/2
D 172.16.4.0/27 [90/40640000] via 172.16.34.4, 00:10:11, Serial0/3
D 172.16.1.0/24 [90/41152000] via 172.16.23.2, 00:31:03, Serial0/2
D 172.16.2.0/24 [90/40640000] via 172.16.23.2, 00:32:17, Serial0/2
D 172.16.4.96/27 [90/40640000] via 172.16.34.4, 00:00:10, Serial0/3
D 172.16.4.64/27 [90/40640000] via 172.16.34.4, 00:00:10, Serial0/3
r3#
172.16.0.0/16 is variably subnetted, 13 subnets, 2 masks
D 172.16.4.32/27 [90/40640000] via 172.16.34.4, 00:00:10, Serial0/3
D 172.16.12.0/24 [90/41024000] via 172.16.23.2, 00:32:17, Serial0/2
D 172.16.4.0/27 [90/40640000] via 172.16.34.4, 00:10:11, Serial0/3
D 172.16.1.0/24 [90/41152000] via 172.16.23.2, 00:31:03, Serial0/2
D 172.16.2.0/24 [90/40640000] via 172.16.23.2, 00:32:17, Serial0/2
D 172.16.4.96/27 [90/40640000] via 172.16.34.4, 00:00:10, Serial0/3
D 172.16.4.64/27 [90/40640000] via 172.16.34.4, 00:00:10, Serial0/3
r3#
r4(config-if)#ip summary-add eigrp 1 172.16.4.0 255.255.255.128
r4(config-if)#
Jul 29 16:34:41: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.3 (Serial0/3) is resync: summary configured
r4(config-if)#
r4(config-if)#
Jul 29 16:34:41: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.3 (Serial0/3) is resync: summary configured
r4(config-if)#
r3#
Jul 29 16:34:09: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.4 (Serial0/3) is resync: peer graceful-restart
r3#sh ip route eigrp
172.16.0.0/16 is variably subnetted, 11 subnets, 3 masks
D 172.16.12.0/24 [90/41024000] via 172.16.23.2, 00:33:08, Serial0/2
D 172.16.4.0/27 [90/40640000] via 172.16.34.4, 00:11:02, Serial0/3
D 172.16.4.0/25 [90/40640000] via 172.16.34.4, 00:00:28, Serial0/3
D 172.16.1.0/24 [90/41152000] via 172.16.23.2, 00:31:53, Serial0/2
D 172.16.2.0/24 [90/40640000] via 172.16.23.2, 00:33:08, Serial0/2
r3#
Jul 29 16:34:09: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.34.4 (Serial0/3) is resync: peer graceful-restart
r3#sh ip route eigrp
172.16.0.0/16 is variably subnetted, 11 subnets, 3 masks
D 172.16.12.0/24 [90/41024000] via 172.16.23.2, 00:33:08, Serial0/2
D 172.16.4.0/27 [90/40640000] via 172.16.34.4, 00:11:02, Serial0/3
D 172.16.4.0/25 [90/40640000] via 172.16.34.4, 00:00:28, Serial0/3
D 172.16.1.0/24 [90/41152000] via 172.16.23.2, 00:31:53, Serial0/2
D 172.16.2.0/24 [90/40640000] via 172.16.23.2, 00:33:08, Serial0/2
r3#
eigrp lab 6 cont...
the results are pouring in...
r1#tclsh
r1(tcl)#foreach address {
+>(tcl)#172.16.1.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.2.1
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#172.16.3.1
+>(tcl)#172.16.3.33
+>(tcl)#172.16.3.65
+>(tcl)#172.16.3.97
+>(tcl)#172.16.34.3
+>(tcl)#172.16.34.4
+>(tcl)#172.16.4.1
+>(tcl)#172.16.4.33
+>(tcl)#172.16.4.65
+>(tcl)#172.16.4.97
+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/30/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/38/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/39/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/70/84 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/37/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/43/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms
r1(tcl)#
r1#tclsh
r1(tcl)#foreach address {
+>(tcl)#172.16.1.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.2.1
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#172.16.3.1
+>(tcl)#172.16.3.33
+>(tcl)#172.16.3.65
+>(tcl)#172.16.3.97
+>(tcl)#172.16.34.3
+>(tcl)#172.16.34.4
+>(tcl)#172.16.4.1
+>(tcl)#172.16.4.33
+>(tcl)#172.16.4.65
+>(tcl)#172.16.4.97
+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/30/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/38/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/39/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/70/84 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/37/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/43/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/44 ms
r1(tcl)#
eigrp lab 6...
the mission...
make the bandwidth on all 64
eigrp 1 no auto-summ
summarize r4's loopbacks
no multicast between r1 and r2
change the hello time between r3 and r4 to 2 seconds
use md5 authentication between r3 and r4
make a tcl script that pings everybody
verify...
turn those mother's out...
make the bandwidth on all 64
eigrp 1 no auto-summ
summarize r4's loopbacks
no multicast between r1 and r2
change the hello time between r3 and r4 to 2 seconds
use md5 authentication between r3 and r4
make a tcl script that pings everybody
verify...
turn those mother's out...
eigrp lab 4 cont...
yuck... time for a little frivolity... at least you built another lab, right?
now that we've made this beautiful little lab, let's ruin it by adding key chains...
ready...
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 31/28
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 8
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "hulk-key"
it's so funny in these labs, they try to make it so serious and shit... "your CIO has specified that the current hello interval for eigrp is not acceptable..." lmao..
ok, change it to two...
r3(config-if)#ip hello-int eigrp 1 2
r3(config-if)#end
r3#sh ip eigrp 1 int det s1/2
IP-EIGRP interfaces for process 100
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/2 0 0/0 0 10/380 520 0
Hello interval is 2 sec
next...
now that we've made this beautiful little lab, let's ruin it by adding key chains...
ready...
r1
key chain hulk-key
key 1
key-string hulk
int e0/0
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
int s1/0
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
int s1/3
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
r2
key chain hulk-key
key 1
key-string hulk
int e0/0
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
int s1/0
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
int s1/2
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
r3
key chain hulk-key
key 1
key-string hulk
int e0/0
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
int s1/2
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
int s1/3
ip authenti key-chain eigrp 1 hulk-key
ip authenti mode eigrp 1 md5
md5 will cause flapping, so do this at home...
r3#sh ip eigrp int det
Se1/2 0 0/0 0 10/380 520 0
Hello interval is 5 sec Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 31/28
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 8
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "hulk-key"
it's so funny in these labs, they try to make it so serious and shit... "your CIO has specified that the current hello interval for eigrp is not acceptable..." lmao..
ok, change it to two...
r3(config-if)#ip hello-int eigrp 1 2
r3(config-if)#end
r3#sh ip eigrp 1 int det s1/2
IP-EIGRP interfaces for process 100
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/2 0 0/0 0 10/380 520 0
Hello interval is 2 sec
next...
net acad labs...
one of the things i liked most about doing the netacad labs for switch is that they are structured, meaning they get you into good habits... of course it's a pain in the ass, but nothing that was ever worth anything wasn't a pain in the ass...
repetition is paramount here; doing things without having to think about them...
i can set up an enterprise switch block in a half hour from scratch... i don't even think about the vlans, the addressing, port channles or hsrp anymore, routing, it's built in...
funny, some people i know talk about hsrp like it's old... well, yeah, it is old, but it works great, and it's the father of ha and redundancy... if you know hsrp, you also know vrrp and glbp, and the idea of vitualization is planted firmly...
don't be jaded when it comes to certain older technologies; they are still taught for very good reason... without a foundation your house falls down... don't be the guy who wants to start at chapter 48, there were 47 chapters you missed along the way... i have no patience for people like that... you'll never be good at building a nexus system if you can't already build a basic switch...
i've been getting into nx-os lately... what you find is everything old is new again...
between junos and nx-os the idea of burying the system under a bunch of aliased commands is becoming obsolete, and the unix command line coming back into the fore of these systems is for me, welcome and refreshing...
if you can't navigate a file system you will be left behind... dust off the old system V and berkeley books; use a linux distro instead of nasty windows as your desktop... get back to where the power is... the gui is your enemy...
when you follow my labs, don't just scrape the configs into your topologies... type em like you got a pair...
repetition is paramount here; doing things without having to think about them...
i can set up an enterprise switch block in a half hour from scratch... i don't even think about the vlans, the addressing, port channles or hsrp anymore, routing, it's built in...
funny, some people i know talk about hsrp like it's old... well, yeah, it is old, but it works great, and it's the father of ha and redundancy... if you know hsrp, you also know vrrp and glbp, and the idea of vitualization is planted firmly...
don't be jaded when it comes to certain older technologies; they are still taught for very good reason... without a foundation your house falls down... don't be the guy who wants to start at chapter 48, there were 47 chapters you missed along the way... i have no patience for people like that... you'll never be good at building a nexus system if you can't already build a basic switch...
i've been getting into nx-os lately... what you find is everything old is new again...
between junos and nx-os the idea of burying the system under a bunch of aliased commands is becoming obsolete, and the unix command line coming back into the fore of these systems is for me, welcome and refreshing...
if you can't navigate a file system you will be left behind... dust off the old system V and berkeley books; use a linux distro instead of nasty windows as your desktop... get back to where the power is... the gui is your enemy...
when you follow my labs, don't just scrape the configs into your topologies... type em like you got a pair...
Saturday, July 28, 2012
eigrp lab 4...
type em out first then slime em in... it's good practice
for all routers:
serv time log date
serv time debug date
no ip domain-loo
line cons 0
pass cisco
login
logg sync
exec-t 60 0
privi lev 15
line vty 0 15
pass cisco
login
logg sync
exec-t 60 0
privi lev 15
then individually...
r1
int lo1
ip add 192.168.1.1 255.255.255.0
int e0/0
descr -->switch
ip add 10.1.1.1 255.255.255.0
no shut
int s1/0
descr -->r2
ip add 172.16.12.1 255.255.255.248
clock ra 64000
band 64
no shut
int s1/3
descr -->r3
ip add 172.16.13.1 255.255.255.248
band 64
no shut
r2
int lo2
ip add 192.168.2.2 255.255.255.0
int e0/0
descr -->switch
ip add 10.1.1.2 255.255.255.0
no shut
int s1/0
descr -->r1
ip add 172.16.12.2 255.255.255.248
band 64
no shut
int s1/2
descr -->r3
ip add 172.16.23.2 255.255.255.248
clock ra 64000
band 64
no shut
r3
int lo3
ip add 192.168.3.3 255.255.255.0
int e0/0
descr -->switch
ip add 10.1.1.3 255.255.255.0
no shut
int s1/3
desc -->r1
ip add 172.16.13.3 255.255.255.248
clock ra 64000
band 64
no shut
int s1/2
descr -->r2
ip add 172.16.23.3 255.255.255.248
band 64
no shut
turn on eigrp for each router, leave auto-summ...
router eigrp 1
netw 192.168.X.0
net 172.16.0.0
net 10.0.0.0
r3#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
3 10.1.1.1 Et0/0 14 00:02:53 16 200 0 19
2 10.1.1.2 Et0/0 14 00:02:54 675 4050 0 21
1 172.16.13.1 Se1/3 10 00:32:20 20 2280 0 18
0 172.16.23.2 Se1/2 10 00:32:35 31 2280 0 20
tclsh
foreach address {
10.1.1.1
172.16.12.1
172.16.13.1
192.168.1.1
10.1.1.2
172.16.12.2
172.16.23.2
192.168.2.2
10.1.1.3
172.16.13.3
172.16.23.3
192.168.3.3
} { ping $address }
for all routers:
serv time log date
serv time debug date
no ip domain-loo
line cons 0
pass cisco
login
logg sync
exec-t 60 0
privi lev 15
line vty 0 15
pass cisco
login
logg sync
exec-t 60 0
privi lev 15
then individually...
r1
int lo1
ip add 192.168.1.1 255.255.255.0
int e0/0
descr -->switch
ip add 10.1.1.1 255.255.255.0
no shut
int s1/0
descr -->r2
ip add 172.16.12.1 255.255.255.248
clock ra 64000
band 64
no shut
int s1/3
descr -->r3
ip add 172.16.13.1 255.255.255.248
band 64
no shut
r2
int lo2
ip add 192.168.2.2 255.255.255.0
int e0/0
descr -->switch
ip add 10.1.1.2 255.255.255.0
no shut
int s1/0
descr -->r1
ip add 172.16.12.2 255.255.255.248
band 64
no shut
int s1/2
descr -->r3
ip add 172.16.23.2 255.255.255.248
clock ra 64000
band 64
no shut
r3
int lo3
ip add 192.168.3.3 255.255.255.0
int e0/0
descr -->switch
ip add 10.1.1.3 255.255.255.0
no shut
int s1/3
desc -->r1
ip add 172.16.13.3 255.255.255.248
clock ra 64000
band 64
no shut
int s1/2
descr -->r2
ip add 172.16.23.3 255.255.255.248
band 64
no shut
turn on eigrp for each router, leave auto-summ...
router eigrp 1
netw 192.168.X.0
net 172.16.0.0
net 10.0.0.0
r1#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
3 10.1.1.3 Et0/0 10 00:01:31 44 264 0 25
2 10.1.1.2 Et0/0 12 00:02:00 30 200 0 21
1 172.16.13.3 Se1/3 12 00:30:52 314 2280 0 23
0 172.16.12.2 Se1/0 14 00:30:52 430 2580 0 19
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
3 10.1.1.3 Et0/0 10 00:01:31 44 264 0 25
2 10.1.1.2 Et0/0 12 00:02:00 30 200 0 21
1 172.16.13.3 Se1/3 12 00:30:52 314 2280 0 23
0 172.16.12.2 Se1/0 14 00:30:52 430 2580 0 19
r2#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
3 10.1.1.3 Et0/0 12 00:02:25 44 264 0 25
2 10.1.1.1 Et0/0 12 00:02:53 783 4698 0 19
1 172.16.12.1 Se1/0 14 00:31:50 33 2280 0 17
0 172.16.23.3 Se1/2 13 00:32:04 284 2280 0 24
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
3 10.1.1.3 Et0/0 12 00:02:25 44 264 0 25
2 10.1.1.1 Et0/0 12 00:02:53 783 4698 0 19
1 172.16.12.1 Se1/0 14 00:31:50 33 2280 0 17
0 172.16.23.3 Se1/2 13 00:32:04 284 2280 0 24
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
3 10.1.1.1 Et0/0 14 00:02:53 16 200 0 19
2 10.1.1.2 Et0/0 14 00:02:54 675 4050 0 21
1 172.16.13.1 Se1/3 10 00:32:20 20 2280 0 18
0 172.16.23.2 Se1/2 10 00:32:35 31 2280 0 20
tclsh
foreach address {
10.1.1.1
172.16.12.1
172.16.13.1
192.168.1.1
10.1.1.2
172.16.12.2
172.16.23.2
192.168.2.2
10.1.1.3
172.16.13.3
172.16.23.3
192.168.3.3
} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/12/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/22/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/12/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
r2(tcl)#
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/12/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/22/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/12/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
r2(tcl)#
eigrp frame lab...
on r1
interface Loopback1
ip address 10.1.1.1 255.255.224.0
!
interface Loopback33
ip address 10.1.33.1 255.255.224.0
!
interface Loopback65
ip address 10.1.65.1 255.255.224.0
!
interface Loopback97
ip address 10.1.97.1 255.255.224.0
!
ip address 10.1.1.1 255.255.224.0
!
interface Loopback33
ip address 10.1.33.1 255.255.224.0
!
interface Loopback65
ip address 10.1.65.1 255.255.224.0
!
interface Loopback97
ip address 10.1.97.1 255.255.224.0
!
interface Loopback161
ip address 10.1.161.1 255.255.224.0
ip address 10.1.161.1 255.255.224.0
on r2
r2(config)#int lo1
r2(config-if)#ip add 10.2.1.1 255.255.224.0
r2(config-if)#int lo33
r2(config-if)#ip add 10.2.33.1 255.255.224.0
r2(config-if)#int lo65
r2(config-if)#ip add 10.2.65.1 255.255.224.0
r2(config-if)#int lo97
r2(config-if)#ip add 10.2.97.1 255.255.224.0
r2(config-if)#int lo129
r2(config-if)#ip add 10.1.129.1 255.255.224.0
r2(config-if)#int lo161
r2(config-if)#ip add 10.2.161.1 255.255.224.0
on r4
interface Loopback1
ip address 10.3.1.1 255.255.224.0
!
interface Loopback33
ip address 10.3.33.1 255.255.224.0
!
interface Loopback65
ip address 10.3.65.1 255.255.224.0
!
interface Loopback97
ip address 10.3.97.1 255.255.224.0
!
interface Loopback129
ip address 10.3.129.1 255.255.224.0
!
interface Loopback161
ip address 10.3.161.1 255.255.224.0
set up the frame switch...
r3fr#sh run (only essential config is shown)
hostname r3fr
!
frame-relay switching
!
interface Serial1/0
no ip address
encapsulation frame-relay IETF
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial1/1 103
!
interface Serial1/1
no ip address
encapsulation frame-relay IETF
clockrate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial1/2 201
frame-relay route 103 interface Serial1/0 301
!
interface Serial1/2
no ip address
encapsulation frame-relay IETF
clockrate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial1/1 102
then set up the interfaces on the various routers...
r1#sh run int s1/1
Building configuration...
Current configuration : 222 bytes
!
interface Serial1/1
ip address 172.16.124.1 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
no frame-relay inverse-arp
Building configuration...
Current configuration : 222 bytes
!
interface Serial1/1
ip address 172.16.124.1 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
no frame-relay inverse-arp
r2#sh run int s1/2
Building configuration...
Current configuration : 212 bytes
!
interface Serial1/2
ip address 172.16.124.2 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.3 201
no frame-relay inverse-arp
Building configuration...
Current configuration : 212 bytes
!
interface Serial1/2
ip address 172.16.124.2 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.3 201
no frame-relay inverse-arp
Building configuration...
Current configuration : 212 bytes
!
interface Serial1/0
ip address 172.16.124.3 255.255.255.248
encapsulation frame-relay IETF
frame-relay map ip 172.16.124.1 301 broadcast
frame-relay map ip 172.16.124.2 301
no frame-relay inverse-arp
every body ping everybody...
r1#ping 172.16.124.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r1#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r1#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/40 ms
r2#ping 172.16.124.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r2#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/19/36 ms
r2#ping 172.16.124.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
r4#ping 172.16.124.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.124.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/37/56 ms
if you want the routers to ping themselves, add maps to their own addresses... i'm not interested...
as was discussed in an earlier lab, bandwidth should match the clock rate... since we are in mr. mcfeely's frame relay land of make believe, do it on the interfaces you can control...
r1#sh run int s1/1 | incl bandwidth
bandwidth 128
bandwidth 128
r2#sh run int s1/2 | incl band
bandwidth 64
bandwidth 64
bandwidth 64
oh boy... we get to turn off auto-summ this time... this is very exciting...
set up eigrp for the major networks...
r1#sh run | begin router
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
do this for r2 and r4 as well... go ahead and scrape... you know you will...
the ip route table for r1 looks good...
r1#sh ip route eigrp
10.0.0.0/19 is subnetted, 17 subnets
D 10.2.0.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.0.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.32.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.32.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.64.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.64.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.96.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.96.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.3.128.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.1.128.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.2.160.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.160.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
10.0.0.0/19 is subnetted, 17 subnets
D 10.2.0.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.0.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.32.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.32.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.64.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.64.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.2.96.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.96.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.3.128.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
D 10.1.128.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.2.160.0 [90/20640000] via 172.16.124.2, 00:12:46, Serial1/1
D 10.3.160.0 [90/20640000] via 172.16.124.3, 00:12:46, Serial1/1
but r2 is looking kinda weak...
r2# sh ip route eigrp
10.0.0.0/19 is subnetted, 11 subnets
D 10.1.0.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.32.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.64.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.96.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
D 10.1.160.0 [90/40640000] via 172.16.124.1, 00:15:36, Serial1/2
r2#
i know you know what's coming... the big no ip split horizon trick... oooooooooooooooooooooooohhhhhhhhhhhhhhhhhhhh...
r1(config)#int s1/1
r1(config-if)#no ip split-horizon eigrp 1
r1(config-if)#no ip split-horizon eigrp 1
IP-EIGRP Route Events debugging is on
00:43:40: IP-EIGRP: 10.2.0.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.0.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.32.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.32.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.64.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.64.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.96.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.96.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.1.128.0/19 - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.1.128.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 10.2.160.0/19
r2#sh - do advertise out Serial1/2
00:43:40: IP-EIGRP: Int 10.2.160.0/19 metric 128256 - 256 128000
00:43:40: IP-EIGRP: 172.16.124.0/29 - do advertise out Serial1/2
00:43:42: IP-EIGRP: Processing incoming UPDATE packet
00:43:42: IP-EIGRP: Int 10.1.0.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.32.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.64.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.96.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 10.1.160.0/19 M 40640000 - 40000000 640000 SM 128256 - 256 128000
00:43:42: IP-EIGRP: Int 172.16.124.0/29 M 41024000 - 40000000 1024000 SM 20512000 - 20000000 512000
00:43:42: IP-EIGRP: 172.16.124.0/29 routing table not updated
00:43:42: IP-EIGRP: Int 10.1.0.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 10.1.32.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 1
r2#sh 0.1.64.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 10.1.96.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Int 10.1.160.0/19 metric 40640000 - 40000000 640000
00:43:42: IP-EIGRP: Processing incoming UPDATE packet
00:43:42: IP-EIGRP: Int 10.2.0.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.0.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.32.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.32.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.64.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.64.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.96.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.96.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.1.128.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.
r2#sh 1.128.0/19 routing table not updated
00:43:42: IP-EIGRP: Int 10.2.160.0/19 M 41152000 - 40000000 1152000 SM 20640000 - 20000000 640000
00:43:42: IP-EIGRP: 10.2.160.0/19 routing table not updated
r2#
it's a twofer...
r2# sh ip route eigrp
10.0.0.0/19 is subnetted, 17 subnets
D 10.3.0.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.0.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.32.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.32.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.64.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.64.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.96.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.96.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
D 10.3.128.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.3.160.0 [90/41152000] via 172.16.124.1, 00:03:51, Serial1/2
D 10.1.160.0 [90/40640000] via 172.16.124.1, 00:04:50, Serial1/2
the book wants to run a tcl script to ping everybody... go ahead...
ok so we know split horizon is on by default and it makes frame misbehave...
who still uses frame?
word is they hang on to frame as a testable subject because it makes routing protocols do weird shit... great...
i made the multicast hello's into unicast with this...
router eigrp 1
network 10.0.0.0
network 172.16.0.0
neighbor 172.16.124.3 Serial1/1
neighbor 172.16.124.2 Serial1/1
no auto-summary
and proved it with some caps below... note destinations, before and after...
Subscribe to:
Posts (Atom)