i love this guy...
http://ardenpackeer.com/tutorials/routeswitch/tutorial-ipv6-tunnels-part-1-manual-gre-ipv6ip-tunnels/
i expect at some point i will go through all the labs on his site... i like that he keeps things narrowly focused with his topologies so that the salient points can be illustrated...
with only 3 routers the frame switch is terribly easy to make...
1:102 goes to 2:201
1:103 goes to 3:301
the interfaces are thus:
r1
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ipv6 address 2001:1:1:1::1/64
!
interface Serial1/0
ip address 10.1.123.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 10.1.123.3 103 broadcast
frame-relay map ip 10.1.123.2 102 broadcast
no frame-relay inverse-arp
r2
interface Loopback0
ip address 10.20.20.20 255.255.255.255
!
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ipv6 address 2001:2:2:2::2/64
interface Serial1/0
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 10.1.123.3 201
frame-relay map ip 10.1.123.1 201 broadcast
no frame-relay inverse-arp
r3
interface Loopback0
ip address 10.30.30.30 255.255.255.255
!
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ipv6 address 2001:3:3:3::3/64
interface Serial1/0
ip address 10.1.123.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 10.1.123.2 301
frame-relay map ip 10.1.123.1 301 broadcast
no frame-relay inverse-arp
add the ospf networks for each router... arden seems to be fond of the zero's although i don't really like that... he also specifically states the router-id as the lo0's in the config... that'll happen anyway...
network 0.0.0.0 255.255.255.255 area 0
i always like to verify the frame map...
R1#sh frame map
Serial1/0 (up): ip 10.1.123.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 10.1.123.3 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active
R3#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.1.123.0/24 is directly connected, Serial1/0
O 10.1.123.1/32 [110/64] via 10.1.123.1, 00:02:01, Serial1/0
O 10.1.123.2/32 [110/128] via 10.1.123.1, 00:01:30, Serial1/0
L 10.1.123.3/32 is directly connected, Serial1/0
O 10.10.10.10/32 [110/65] via 10.1.123.1, 00:02:01, Serial1/0
O 10.20.20.20/32 [110/129] via 10.1.123.1, 00:01:30, Serial1/0
C 10.30.30.30/32 is directly connected, Loopback0
R3#ping 10.1.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/36/44 ms
R3#ping 10.1.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/17/24 ms
connectivity established... except for ipv6...
No comments:
Post a Comment