i've begun actually to enjoy jerking around with frame lately... it takes more effort to avoid it...
hub and spoke... ip only... the interfaces ping because they are in the same subnet...
R1#sh run int s2/0
Building configuration...
Current configuration : 227 bytes
!
interface Serial2/0
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.1.1.3 103 broadcast
frame-relay map ip 10.1.1.2 102 broadcast
no frame-relay inverse-arp
R2#sh run int s2/0
Building configuration...
Current configuration : 217 bytes
!
interface Serial2/0
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.1.1.1 202 broadcast
frame-relay map ip 10.1.1.3 202
no frame-relay inverse-arp
R3#sh run int s2/0
Building configuration...
Current configuration : 217 bytes
!
interface Serial2/0
ip address 10.1.1.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.1.1.2 303
frame-relay map ip 10.1.1.1 303 broadcast
no frame-relay inverse-arp
R3#trace 10.1.1.2
Type escape sequence to abort.
Tracing the route to 10.1.1.2
VRF info: (vrf in name/id, vrf out name/id)
1 10.1.1.1 28 msec 36 msec 20 msec
2 10.1.1.2 32 msec * 48 msec
the ip ospf interface command gives you a lot of flexibility with the topology...
choose your weapons...
R1(config)#router ospf 1
R1(config-router)#netw 10.1.1.0 0.0.0.255 area 0
R1(config-router)#netw 1.1.1.0 0.0.0.255 area 0
R2(config)#router ospf 1
R2(config-router)#netw 10.1.1.0 0.0.0.255 area 0
R2(config-router)#netw 2.2.2.0 0.0.0.255 area 0
R2(config-router)#end
R3(config)#router ospf 1
R3(config-router)#netw 10.1.1.0 0.0.0.255 area 0
R3(config-router)#netw 3.3.3.0 0.0.0.255 area 0
note: you'll get no adjacencies until you declare the interface network types...
once ip ospf network point-to-multipoint is placed on the interfaces, you have a happy ospf situation...
R3#sh ip route | b Gate
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 10.1.1.1, 00:02:11, Serial2/0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/129] via 10.1.1.1, 00:02:11, Serial2/0
3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 3.3.3.0/24 is directly connected, Loopback0
L 3.3.3.3/32 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial2/0
O 10.1.1.1/32 [110/64] via 10.1.1.1, 00:02:11, Serial2/0
O 10.1.1.2/32 [110/128] via 10.1.1.1, 00:02:11, Serial2/0
L 10.1.1.3/32 is directly connected, Serial2/0
R3#sh ip ospf int
Loopback0 is up, line protocol is up
Internet Address 3.3.3.3/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 3.3.3.3, Network Type LOOPBACK, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Loopback interface is treated as a stub Host
Serial2/0 is up, line protocol is up
Internet Address 10.1.1.3/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
Topology-MTID Cost Disabled Shutdown Topology Name
0 64 no no Base
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1
Suppress hello for 0 neighbor(s)
the loopbacks show up as loopbacks... make them networks with ip ospf network point-to-point
R1#sh ip ospf int lo0
Loopback0 is up, line protocol is up
Internet Address 1.1.1.1/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
the points network types have no dr/bdr (point-to-point and multipoint)
R1#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:01:58 10.1.1.2 Serial2/0
3.3.3.3 0 FULL/ - 00:01:47 10.1.1.3 Serial2/0
so there is no need to worry over ospf priority on the spokes...
R2#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:01:53 10.1.1.1 Serial2/0
now make an ipv6 tunnel between r2 and r3...
R3#sh run int tun0
Building configuration...
Current configuration : 118 bytes
!
interface Tunnel0
no ip address
ipv6 address 2001::3/64
tunnel source 10.1.1.3
tunnel destination 10.1.1.2
R3#ping 2001::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/32/40 ms
change the tunnel mode to ipv6ip...
note the encapsulation type...
No comments:
Post a Comment