i like this topology, it looks like a spaceship...
pay no attention to that man behind the curtain...
this is pretty tough, trying to second guess the guy and he doesn't give the routing statements... with eigrp i always use wild cards although you often don't need them... it's a habit from ospf... err on the side of caution... i'm skipping past his broken illustration that depicts why subnets for eigrp distribution into ospf are important... remember that the subnets statement in eigrp is important... good...
so put up the routing statements... my rule of thumb, be specific, even if it's eigrp... then redist...
r#sh run | beg router
router eigrp 1
network 172.16.0.0
network 192.168.3.0
network 192.168.4.0
redistribute ospf 1 metric 1000 100 1 255 1500
redistribute eigrp 2
passive-interface FastEthernet0/0
!
!
router eigrp 2
network 172.16.0.0
network 192.168.4.0
redistribute ospf 1 metric 1000 100 1 255 1500
redistribute eigrp 1
!
router ospf 1
redistribute eigrp 1 subnets
redistribute eigrp 2 metric 100 subnets
network 192.168.3.33 0.0.0.0 area 0
network 192.168.3.32 0.0.0.31 area 0
default-metric 50
with redist, from-to.. below is my output...
h#sh ip route | excl L | incl loop
Gateway of last resort is not set172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2 172.16.1.0/24 [110/100] via 192.168.3.33, 00:48:49, FastEthernet0/0
O E2 172.16.2.20/30 [110/50] via 192.168.3.33, 00:48:49, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Loopback3
O E2 192.168.2.0/24 [110/50] via 192.168.3.33, 00:00:23, FastEthernet0/0
192.168.3.0/24 is variably subnetted, 9 subnets, 2 masks
C 192.168.3.32/27 is directly connected, FastEthernet0/0
C 192.168.3.64/27 is directly connected, Loopback1
C 192.168.3.96/27 is directly connected, Loopback2
O E2 192.168.3.128/27 [110/50] via 192.168.3.33, 00:48:49, FastEthernet0/0
O E2 192.168.3.160/27 [110/50] via 192.168.3.33, 00:00:23, FastEthernet0/0
O E2 192.168.3.192/27 [110/50] via 192.168.3.33, 00:00:23, FastEthernet0/0
192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
O E2 192.168.4.4/30 [110/50] via 192.168.3.33, 00:48:49, FastEthernet0/0
O E2 192.168.4.72/29 [110/100] via 192.168.3.33, 00:48:49, FastEthernet0/0
and here is the text...
the output differs slightly... i think it's a code issue... anyway, i backtracked on the eigrp's and made them all classful but the output didn't change to exactly match... the major classful prefixes do not show up as e2's alone on mine... big friggin deal... i still prefer being specific with wc's in eigrp, whether or not it shows up in the output...
can i get to everything... bet your ass...
e1 vs e2 from brian mcgahan
http://blog.ine.com/2011/04/04/understanding-ospf-external-route-path-selection/
Regardless of a route’s metric or administrative distance, OSPF will choose routes in the following order:
Intra-Area (O)
Inter-Area (O IA)
External Type 1 (E1)
External Type 2 (E2)
NSSA Type 1 (N1)
NSSA Type 2 (N2)
this lab is not ideal for testing path selection... something that is ideal is the extended ping command using the record option... if you haven't tried that yet, you should...
No comments:
Post a Comment