from brian mcgahan... this looks like a nice continuation for where that last lab was going...
Intra-Area (O)
Inter-Area (O IA)
External Type 1 (E1)
External Type 2 (E2)
NSSA Type 1 (N1)
NSSA Type 2 (N2)
this is the order of preference...
there's some things i want to look at here... but i'm changing the numbers...
does my ass look big in these ellipses?
r1
int lo1
ip add 1.1.1.1 255.255.255.0
int f0/0
ip add 10.1.1.1 255.255.255.0
no shut
int f1/1
ip add 10.1.2.1 255.255.255.0
no shut
r2
int f0/0
ip add 10.1.1.2 255.255.255.0
no shut
int s1/1
ip add 192.168.1.1 255.255.255.0
clock rat 128000
band 128
no shut
r3
int f0/0
ip add 10.1.2.2 255.255.255.0
no shut
int s1/1
ip add 192.168.2.1 255.255.255.0
clock rat 128000
band 128
no shut
r4
int s1/1
ip add 192.168.1.2 255.255.255.0
band 128
no shut
int f0/0
ip add 172.16.1.2 255.255.255.0
no shut
r5
int s1/1
ip add 192.168.2.2 255.255.255.0
band 128
no shut
int f0/0
ip add 172.16.2.2 255.255.255.0
no shut
r6
int lo6
ip add 6.6.6.6 255.255.255.0
int f0/0
ip add 172.16.1.1 255.255.255.0
no shut
int f0/1
ip add 172.16.2.1 255.255.255.0
no shut
there you have it... link ping... yeah they work...
i didn't get the perspective too well... his diagram is cooler...
add the routing protocols...i'm not doing it for you... i purposely don't save after the interfaces are built for practice later... right... riiiiiiiiiiiiiigggghhhhhtttt..
r1#sh ip route | excl l | incl loop
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
L 1.1.1.1/32 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.1/32 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
L 10.1.2.1/32 is directly connected, FastEthernet1/1
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 00:20:06, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:01:04, FastEthernet1/1
r1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
r1#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
L 1.1.1.1/32 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.1/32 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
L 10.1.2.1/32 is directly connected, FastEthernet1/1
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 00:20:06, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:01:04, FastEthernet1/1
r1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
r1#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
r1#ping 192.168.1.2 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
r1#ping 192.168.2.2 source 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8
so this is very nice and there's a lot to do here... thanks, brian mcgahan...
make the ospf loopback a point-to-point network so it is perceived as a network, not a host...
r2#sh ip route 1.1.1.1
Routing entry for 1.1.1.0/24
Known via "ospf 1", distance 110, metric 2, type intra area
Last update from 10.1.1.1 on FastEthernet0/0, 00:27:44 ago
Routing Descriptor Blocks:
* 10.1.1.1, from 1.1.1.1, 00:27:44 ago, via FastEthernet0/0
Route metric is 2, traffic share count is 1
r4#sh run | beg router
router eigrp 1
network 172.16.0.0
redistribute ospf 1 metric 1000 1 1 255 1500
i made r4 and r5 the same for now...
r6#sh ip route | excl L | inc loop
Gateway of last resort is not set1.0.0.0/24 is subnetted, 1 subnets
D EX 1.1.1.0 [170/2562816] via 172.16.2.2, 00:03:17, FastEthernet0/1
[170/2562816] via 172.16.1.2, 00:03:17, FastEthernet0/0
6.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 6.6.6.0/24 is directly connected, Loopback6
10.0.0.0/24 is subnetted, 2 subnets
D EX 10.1.1.0 [170/2562816] via 172.16.2.2, 00:03:17, FastEthernet0/1
[170/2562816] via 172.16.1.2, 00:03:17, FastEthernet0/0
D EX 10.1.2.0 [170/2562816] via 172.16.2.2, 00:03:17, FastEthernet0/1
[170/2562816] via 172.16.1.2, 00:03:17, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.1.0/24 is directly connected, FastEthernet0/0
C 172.16.2.0/24 is directly connected, FastEthernet0/1
D EX 192.168.1.0/24 [170/2562816] via 172.16.2.2, 00:03:17, FastEthernet0/1
[170/2562816] via 172.16.1.2, 00:03:17, FastEthernet0/0
D EX 192.168.2.0/24 [170/2562816] via 172.16.2.2, 00:03:17, FastEthernet0/1
[170/2562816] via 172.16.1.2, 00:03:17, FastEthernet0/0
r1#sh ip route | excl L | incl loop
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 00:54:47, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:35:45, FastEthernet1/1
redist eigrp 1 subnets
r1#sh ip route | excl L | incl loop
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.6.6.0 [110/20] via 10.1.1.2, 00:00:08, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
172.16.0.0/24 is subnetted, 2 subnets
O E2 172.16.1.0 [110/20] via 10.1.1.2, 00:00:08, FastEthernet0/0
O E2 172.16.2.0 [110/20] via 10.1.1.2, 00:00:08, FastEthernet0/0
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 00:55:37, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:36:35, FastEthernet1/1
do it for both r4 and r5...
r1#sh ip route | excl L | incl loop
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.6.6.0 [110/20] via 10.1.2.2, 00:02:49, FastEthernet1/1
[110/20] via 10.1.1.2, 00:04:32, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
172.16.0.0/24 is subnetted, 2 subnets
O E2 172.16.1.0 [110/20] via 10.1.2.2, 00:02:49, FastEthernet1/1
[110/20] via 10.1.1.2, 00:04:32, FastEthernet0/0
O E2 172.16.2.0 [110/20] via 10.1.2.2, 00:02:49, FastEthernet1/1
[110/20] via 10.1.1.2, 00:04:32, FastEthernet0/0
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 01:00:01, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:40:59, FastEthernet1/1
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
6.0.0.0/24 is subnetted, 1 subnets
O E2 6.6.6.0 [110/20] via 10.1.2.2, 00:02:49, FastEthernet1/1
[110/20] via 10.1.1.2, 00:04:32, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
172.16.0.0/24 is subnetted, 2 subnets
O E2 172.16.1.0 [110/20] via 10.1.2.2, 00:02:49, FastEthernet1/1
[110/20] via 10.1.1.2, 00:04:32, FastEthernet0/0
O E2 172.16.2.0 [110/20] via 10.1.2.2, 00:02:49, FastEthernet1/1
[110/20] via 10.1.1.2, 00:04:32, FastEthernet0/0
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 01:00:01, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:40:59, FastEthernet1/1
r1#ping 6.6.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
the redistribution is exactly the same for r4 and r5... the output has not changed with the inclusion of r5 above...
with this basic redistribution i want to examine the path the traffic takes... press the record button...
r6#ping
Protocol [ip]:
Target IP address: 1.1.1.1
Repeat count [5]: 1
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 6.6.6.6
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: record
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 6.6.6.6
Packet has IP options: Total option bytes= 39, padded length=40
Record route: <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
Reply to request 0 (44 ms). Received packet has options
Total option bytes= 40, padded length=40
Record route:
(172.16.2.1)
(192.168.2.2)
(10.1.2.2)
(10.1.2.1)
(10.1.1.1)
(192.168.1.1)
(172.16.1.2)
(172.16.1.1) <*>
(0.0.0.0)
End of list
the record feature is sweet... look at the path...
it makes a round trip from r6-->r5-->r3-->r1 then back r2--r4--r6... out on the odd's, in on the even's...
i have network wood, and if you don't, go be a server guy or something...
you can see the world like this:
yuck...
No comments:
Post a Comment