on our beloved mcgahan topology, replace eigrp 2 with ospf area 2...
virtual links...
r4#sh run | beg router
router ospf 1
network 172.16.0.0 0.0.255.255 area 2
network 192.168.1.0 0.0.0.255 area 1
router ospf 1
network 172.16.0.0 0.0.255.255 area 2
network 192.168.1.0 0.0.0.255 area 1
r5#sh run | beg router
router ospf 1
network 172.16.0.0 0.0.255.255 area 2
network 192.168.2.0 0.0.0.255 area 1
router ospf 1
network 172.16.0.0 0.0.255.255 area 2
network 192.168.2.0 0.0.0.255 area 1
router ospf 1
network 8.8.8.0 0.0.0.255 area 2
network 172.16.0.0 0.0.255.255 area 2
not much effort to change from eigrp...
r6#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
192.168.2.2 1 FULL/DR 00:00:32 172.16.2.2 FastEthernet0/1
192.168.1.2 1 FULL/DR 00:00:33 172.16.1.2 FastEthernet0/0
the original topology is found here...
http://insearchofthecert.blogspot.com/2012/09/ine-lab-from-their-site.html
all the addressing is the same, just change out eigrp...
r1#sh ip ospf
Routing Process "ospf 1" with ID 1.1.1.1
area 2 is not showing up from r1's perspective because it has no connection to the backbone area, area 0... for a discussion on this, go here...
http://insearchofthecert.blogspot.com/2012/08/ospf-lab-3.html
r1#sh ip route | excl L | inc loop
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 00:28:39, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:27:46, FastEthernet1/1
we know for virtual links to work an ospf bridge needs to be established between the backbone area and the transit area, to our long lost area, area 2 in this case... we also know that knowing the router id's in order to make the bridge work is vital...
with this topology, it's a little more tricky because the transit area spans 2 routers... the first tip off that the link will not be built on r1 is the fact that r1 can get to r4 and/or r5... the next tip off that the link will not be built on r6 either is the fact that r6 can get to r4 and/or r5... the bridge needs to span the networks 172.16 and 192.168, not the far end router id's 1.1.1.1 and 8.8.8.8...
the virtual link(s) need to be built between r3 and r5 and/or r2 and r4...
now that you've determined where, you'll need the router id's...
r3#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/DR 00:00:39 10.1.2.1 FastEthernet0/0
192.168.2.2 0 FULL/ - 00:00:39 192.168.2.2 Serial1/1
r5#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
192.168.2.1 0 FULL/ - 00:00:35 192.168.2.1 Serial1/1
8.8.8.8 1 FULL/BDR 00:00:32 172.16.2.1 FastEthernet0/0
r3
area 1 virtual-link 192.168.2.2
r5
area 1 virtual-link 192.168.2.1
r3(config-router)#area 1 virtual-link 192.168.2.2
r3(config-router)#end
r3#
*Sep 3 14:51:09: %SYS-5-CONFIG_I: Configured from console by console
*Sep 3 14:51:09: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.2.2 on OSPF_VL0 from LOADING to FULL, Loading Done
r3(config-router)#end
r3#
*Sep 3 14:51:09: %SYS-5-CONFIG_I: Configured from console by console
*Sep 3 14:51:09: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.2.2 on OSPF_VL0 from LOADING to FULL, Loading Done
*Sep 3 14:51:09: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.2.1 on OSPF_VL0 from LOADING to FULL, Loading Done
r5(config-router)#end
if you do it fast enough you won't get any virtual link errors...
r1#sh ip route | excl L | inc loop
Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
8.0.0.0/24 is subnetted, 1 subnets
O IA 8.8.8.0 [110/784] via 10.1.2.2, 00:01:31, FastEthernet1/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.1.0 [110/784] via 10.1.2.2, 00:01:31, FastEthernet1/1
O IA 172.16.2.0 [110/783] via 10.1.2.2, 00:01:31, FastEthernet1/1
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 00:50:38, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:49:45, FastEthernet1/1
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback1
8.0.0.0/24 is subnetted, 1 subnets
O IA 8.8.8.0 [110/784] via 10.1.2.2, 00:01:31, FastEthernet1/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
C 10.1.2.0/24 is directly connected, FastEthernet1/1
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.1.0 [110/784] via 10.1.2.2, 00:01:31, FastEthernet1/1
O IA 172.16.2.0 [110/783] via 10.1.2.2, 00:01:31, FastEthernet1/1
O IA 192.168.1.0/24 [110/782] via 10.1.1.2, 00:50:38, FastEthernet0/0
O IA 192.168.2.0/24 [110/782] via 10.1.2.2, 00:49:45, FastEthernet1/1
r6# sh ip route | excl L | inc loop
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
O IA 1.1.1.0 [110/784] via 172.16.2.2, 00:03:39, FastEthernet0/1
6.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 6.6.6.0/24 is directly connected, Loopback6
8.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 8.8.8.0/24 is directly connected, Loopback8
10.0.0.0/24 is subnetted, 2 subnets
O IA 10.1.1.0 [110/784] via 172.16.2.2, 00:03:39, FastEthernet0/1
O IA 10.1.2.0 [110/783] via 172.16.2.2, 00:03:39, FastEthernet0/1
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.1.0/24 is directly connected, FastEthernet0/0
C 172.16.2.0/24 is directly connected, FastEthernet0/1
O IA 192.168.1.0/24 [110/1565] via 172.16.2.2, 00:03:39, FastEthernet0/1
O IA 192.168.2.0/24 [110/782] via 172.16.2.2, 00:03:44, FastEthernet0/1
note the spanned routes are not external, but ia's...
if it's in the routing table, you know damn well you can get to it...
r1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms
note r2 can't get to 8.8.8.8...
r2#sh ip route | exc L | inc loop
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
O 1.1.1.0 [110/2] via 10.1.1.1, 00:59:15, FastEthernet0/0
8.0.0.0/24 is subnetted, 1 subnets
O IA 8.8.8.0 [110/785] via 10.1.1.1, 00:09:57, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
O 10.1.2.0/24 [110/2] via 10.1.1.1, 00:59:15, FastEthernet0/0
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.1.0 [110/785] via 10.1.1.1, 00:09:57, FastEthernet0/0
O IA 172.16.2.0 [110/784] via 10.1.1.1, 00:09:57, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Serial1/1
O IA 192.168.2.0/24 [110/783] via 10.1.1.1, 00:58:12, FastEthernet0/0
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
O 1.1.1.0 [110/2] via 10.1.1.1, 00:59:15, FastEthernet0/0
8.0.0.0/24 is subnetted, 1 subnets
O IA 8.8.8.0 [110/785] via 10.1.1.1, 00:09:57, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
O 10.1.2.0/24 [110/2] via 10.1.1.1, 00:59:15, FastEthernet0/0
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.1.0 [110/785] via 10.1.1.1, 00:09:57, FastEthernet0/0
O IA 172.16.2.0 [110/784] via 10.1.1.1, 00:09:57, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Serial1/1
O IA 192.168.2.0/24 [110/783] via 10.1.1.1, 00:58:12, FastEthernet0/0
but it can ping it because it goes back around the through r1 to get there...
r2#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
Sending 2, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
Packet has IP options: Total option bytes= 39, padded length=40
Reply to request 0 (20 ms). Received packet has options
Total option bytes= 40, padded length=40
Record route:
(10.1.1.2)
(10.1.2.1)
(192.168.2.1)
(172.16.2.2)
(172.16.2.1)
(172.16.2.1)
(192.168.2.2)
(10.1.2.2)
(10.1.1.1)
<*>
End of list
Reply to request 1 (32 ms). Received packet has options
Total option bytes= 40, padded length=40
Record route:
(10.1.1.2)
(10.1.2.1)
(192.168.2.1)
(172.16.2.2)
(172.16.2.1)
(172.16.2.1)
(192.168.2.2)
(10.1.2.2)
(10.1.1.1)
<*>
it goes back to r1 and then rides the 2's to and from... you just love extended ping with record, don't you...
i wasn't fast enough putting them on r2 and r4...
r2(config)#router ospf 1
r2(config-router)#area 1 virtual-link 192.168.1.2
*Sep 3 15:11:41: %OSPF-4-ERRRCV: Received invalid packet: mismatched area ID, from backbone area must be virtual-link but not found from 192.168.1.2, Serial1/1
r2(config-router)#area 1 virtual-link 192.168.1.2
r2(config-router)#
*Sep 3 15:11:47: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.2 on OSPF_VL0 from LOADING to FULL, Loading Done
Sending 2, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
Packet has IP options: Total option bytes= 39, padded length=40
Reply to request 0 (12 ms). Received packet has options
Total option bytes= 40, padded length=40
Record route:
(192.168.1.1)
(172.16.1.2)
(172.16.1.1)
(172.16.1.1)
(192.168.1.2)
(192.168.1.1) <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
End of list
Reply to request 1 (8 ms). Received packet has options
Total option bytes= 40, padded length=40
Record route:
(192.168.1.1)
(172.16.1.2)
(172.16.1.1)
(172.16.1.1)
(192.168.1.2)
(192.168.1.1) <*>
it rides the one's now... say you love extended ping with record now, don't be shy...
and for those interested, this guy was a genius... look what he does to these jaded, self important butt sticks...
i'll watch the time...
No comments:
Post a Comment