r1#sh run | begin router
router bgp 100
bgp log-neighbor-changes
neighbor 192.168.1.225 remote-as 200
router bgp 100
bgp log-neighbor-changes
neighbor 192.168.1.225 remote-as 200
r2#sh run | beg router
router bgp 200
bgp log-neighbor-changes
neighbor 192.168.1.226 remote-as 100
router bgp 200
bgp log-neighbor-changes
neighbor 192.168.1.226 remote-as 100
r2#
*Aug 24 18:05:23: %BGP-5-ADJCHANGE: neighbor 192.168.1.226 Up
*Aug 24 18:05:23: %BGP-5-ADJCHANGE: neighbor 192.168.1.226 Up
BGP neighbor is 192.168.1.226, remote AS 100, external link
BGP version 4, remote router ID 192.168.1.226
BGP state = Established, up for 00:03:32
Last read 00:00:48, last write 00:00:52, hold time is 180, keepalive interval is 60 seconds
Neighbor sessions:
1 active, is not multisession capable (disabled)
Neighbor capabilities:
Route refresh: advertised and received(new)
Four-octets ASN Capability: advertised and received
Address family IPv4 Unicast: advertised and received
Enhanced Refresh Capability: advertised and received
Multisession Capability:
Stateful switchover support enabled: NO for session 1
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 1 1
Keepalives: 5 5
Route Refresh: 0 0
Total: 7 7
Default minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
Session: 192.168.1.226
BGP table version 1, neighbor version 1/0
Output queue size : 0
Index 2, Advertise bit 0
2 update-group member
Slow-peer detection is disabled
Slow-peer split-update-group dynamic is disabled
Sent Rcvd
Prefix activity: ---- ----
Prefixes Current: 0 0
Prefixes Total: 0 0
Implicit Withdraw: 0 0
Explicit Withdraw: 0 0
Used as bestpath: n/a 0
Used as multipath: n/a 0
Outbound Inbound
Local Policy Denied Prefixes: -------- -------
Total: 0 0
Number of NLRIs in the update sent: max 0, min 0
Last detected as dynamic slow peer: never
Dynamic slow peer recovered: never
Refresh Epoch: 1
Last Sent Refresh Start-of-rib: never
Last Sent Refresh End-of-rib: never
Last Received Refresh Start-of-rib: never
Last Received Refresh End-of-rib: never
Sent Rcvd
Refresh activity: ---- ----
Refresh Start-of-RIB 0 0
Refresh End-of-RIB 0 0
Address tracking is enabled, the RIB does have a route to 192.168.1.226
Connections established 2; dropped 1
Last reset 00:04:04, due to BGP Notification received, CEASE: unknown subcode
Transport(tcp) path-mtu-discovery is enabled
Graceful-Restart is disabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled
Mininum incoming TTL 0, Outgoing TTL 1
Local host: 192.168.1.225, Local port: 60301
Foreign host: 192.168.1.226, Foreign port: 179
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
Event Timers (current time is 0xE434C):
Timer Starts Wakeups Next
Retrans 7 0 0x0
TimeWait 0 0 0x0
AckHold 6 4 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 1 0 0x142B74
DeadWait 0 0 0x0
Linger 0 0 0x0
iss: 4197193326 snduna: 4197193502 sndnxt: 4197193502 sndwnd: 16209
irs: 1924916453 rcvnxt: 1924916629 rcvwnd: 16209 delrcvwnd: 175
SRTT: 182 ms, RTTO: 1073 ms, RTV: 891 ms, KRTT: 0 ms
minRTT: 4 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: none
Option Flags: higher precendence, nagle, path mtu capable
Datagrams (max data segment is 1460 bytes):
Rcvd: 12 (out of order: 0), with data: 7, total data bytes: 175
Sent: 13 (retransmit: 0 fastretransmit: 0),with data: 7, total data bytes: 175
the state, is it's finite state machine...
add another router with copper...
note in the below diagram the networks are 192.168.1.220/30 and 1.224/30. the interface addresses are correct... i'm not fixing the diagram for that flaw... so there...
router bgp 100
neighbor 192.168.1.222 remote-as 100
neighbor 192.168.1.225 remote-as 200
notice the rid for r1...
r3#sh ip bgp neigh
BGP neighbor is 192.168.1.221, remote AS 100, internal link
BGP version 4, remote router ID 192.168.1.226
BGP state = Established, up for 00:03:09
the neighbor is .221 but the rid is it's highest interface which happens to be connected to as200...
the rules for rid's are just like ospf... it'll choose the highest loopback, and without a loopback, it chooses the highest physical interface... using a loopback is preferred... for a discussion of this, go here:
http://defaultnetworking.blogspot.com/2012/05/advantages-of-loopback-interfaces-on.html
also, according to doyle...
Cisco’s BGP continues to use a router ID learned from a physical interface, even if the interface subsequently fails or is deleted. Therefore, the stability of a loopback interface is only a minor advantage. The primary benefit is the capability to control the router ID, making it easily distinguishable from other IP addresses.
add a loopback on r1...
r1(config)#interface loopback 0
r1(config-if)#ip address 192.168.255.254 255.255.255.255
r1(config-if)#end
r1#
*Aug 24 19:10:30: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
r1#
*Aug 24 19:10:31: %SYS-5-CONFIG_I: Configured from console by console
r1#clear ip bgp *
r1#
*Aug 24 19:10:48: %BGP-5-ADJCHANGE: neighbor 192.168.1.222 Down User reset
*Aug 24 19:10:48: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.222 IPv4 Unicast topology base removed from session User reset
*Aug 24 19:10:48: %BGP-5-ADJCHANGE: neighbor 192.168.1.225 Down User reset
*Aug 24 19:10:48: %BGP_SESSION-5-ADJCHANGE: neighbor 192.168.1.225 IPv4 Unicast topology base removed from session User reset
*Aug 24 19:10:48: %BGP-5-ADJCHANGE: neighbor 192.168.1.225 Up
*Aug 24 19:10:48: %BGP-5-ADJCHANGE: neighbor 192.168.1.222 Up
you have to clear bgp for it to show up...
r3# sh ip bgp neigh
BGP neighbor is 192.168.1.221, remote AS 100, internal link
BGP version 4, remote router ID 192.168.255.254
BGP state = Established, up for 00:01:21
but you knew that...
you can also set it manually using bgp router-id x.x.x.x
No comments:
Post a Comment