build it... you know you want to... make the clock rate 64000
here's the skinny...
set up r1-r2 ints and lo's in area 0, of course...
then ip ospf netw point-to-p to each lo int...
without this they will be stubs in the output of sh ip ospf int... for an excellent demonstration of this, go here...
http://www.rogerperkin.co.uk/ccie/index.php/ospf/ccie-troubleshooting-ospf-hello-mismatch/
just one of those craz-azy ospf kinda things... without the point-to-point statement it shows up as a host /32, with it, it shows up as a network or /24
r2#sh ip route
(without point-to-point on the loopback of r1)
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.1.1.1/32 [110/65] via 10.1.12.1, 00:01:56, Serial1/1
C 10.1.2.0/24 is directly connected, Loopback2
L 10.1.2.1/32 is directly connected, Loopback2
C 10.1.12.0/24 is directly connected, Serial1/1
L 10.1.12.2/32 is directly connected, Serial1/1
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.2/32 is directly connected, Serial1/3
r2#sh ip route
(with point-to-point on the loopback of r1)
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.1.1.0/24 [110/65] via 10.1.12.1, 00:00:05, Serial1/1
C 10.1.2.0/24 is directly connected, Loopback2
L 10.1.2.1/32 is directly connected, Loopback2
C 10.1.12.0/24 is directly connected, Serial1/1
L 10.1.12.2/32 is directly connected, Serial1/1
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.2/32 is directly connected, Serial1/3
r2#
verify the neighbor states with ip ospf neigh and the presence of loopbacks in sh ip route...
add the link from r2 to r3 and the point-to-point statement on lo3 of r3 only...
r2#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 0 FULL/ - 00:00:37 10.1.12.1 Serial1/1
10.1.3.1 0 FULL/ - 00:00:33 10.1.23.3 Serial1/3
r2#
note ia routes on r1 but not on r2...
r1#sh ip route ospf
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.1.2.0/24 [110/65] via 10.1.12.2, 00:10:52, Serial1/1
O IA 10.1.3.0/24 [110/129] via 10.1.12.2, 00:10:52, Serial1/1
O IA 10.1.23.0/24 [110/128] via 10.1.12.2, 00:10:52, Serial1/1
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.1.2.0/24 [110/65] via 10.1.12.2, 00:10:52, Serial1/1
O IA 10.1.3.0/24 [110/129] via 10.1.12.2, 00:10:52, Serial1/1
O IA 10.1.23.0/24 [110/128] via 10.1.12.2, 00:10:52, Serial1/1
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O 10.1.1.0/24 [110/65] via 10.1.12.1, 00:07:30, Serial1/1
O 10.1.3.0/24 [110/65] via 10.1.23.3, 00:07:30, Serial1/3
r2#
...because it is an abr for each area...
r1#tclsh
r1(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#10.1.12.1
+>(tcl)#10.1.12.2
+>(tcl)#10.1.23.2
+>(tcl)#10.1.23.3
+>(tcl)#172.20.200.1
+>(tcl)#} {
+>(tcl)#ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.20.200.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r1(tcl)#
note the abject failure of lo20 for being a non-hacker by not participating in ospf...
bad loopback, bad...
give r2 and r3 a case of the stubs...
r2(config)#router ospf 1
r2(config-router)#area 23 stub
r2(config-router)#
*Aug 5 13:06:25: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.3.1 on Serial1/3 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
r2(config-router)#
*Aug 5 13:07:02: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.3.1 on Serial1/3 from LOADING to FULL, Loading Done
r2(config-router)#
r2(config-router)#area 23 stub
r2(config-router)#
*Aug 5 13:06:25: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.3.1 on Serial1/3 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
r2(config-router)#
*Aug 5 13:07:02: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.3.1 on Serial1/3 from LOADING to FULL, Loading Done
r2(config-router)#
r3(config-router)#area 23 stub
r3(config-router)#
*Aug 5 13:06:56: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
r3(config-router)#
*Aug 5 13:07:01: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from LOADING to FULL, Loading Done
r3(config-router)#
whoops...
r3#sh ip route ospf
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:04:01, Serial1/3
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA 10.1.1.0/24 [110/129] via 10.1.23.2, 00:04:01, Serial1/3
O IA 10.1.2.0/24 [110/65] via 10.1.23.2, 00:04:01, Serial1/3
O IA 10.1.12.0/24 [110/128] via 10.1.23.2, 00:04:01, Serial1/3
r3#
a stub router cannot receive external routes... only default and inter-area... the horror of it all...
look at the area types...
r2#sh ip ospf
Routing Process "ospf 1" with ID 10.1.2.1
Start time: 00:00:11.876, Time elapsed: 02:44:16.412
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 1 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:09:15.640 ago
SPF algorithm executed 6 times
Area ranges are
Number of LSA 4. Checksum Sum 0x019A61
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 23
Number of interfaces in this area is 1
It is a stub area
Generates stub default route with cost 1
Area has no authentication
SPF algorithm last executed 00:08:34.176 ago
SPF algorithm executed 6 times
Area ranges are
Number of LSA 6. Checksum Sum 0x01B58A
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
from: http://users.lmi.net/canepa/subdir/ospf_fundamentals.html
OSPF Areas Types
Normal
Areas: These areas can either be standard areas or transit (backbone)
areas. Standard areas are defined as areas that can accept intra-area,
inter-area and external routes. The backbone area is the central area to which
all other areas in OSPF connect.
Note: Intra-area
routes refer to updates that are passed within the area. Inter-area routes
refer to updates that are passed between areas. External routes refer to updates
passed from another routing protocol into the OSPF domain by the Autonomous
System Border Router (ASBR).
Stub
Areas: These areas do not accept routes belonging to external autonomous
systems (AS); however, these areas have inter-area and intra-area routes. In
order to reach the outside networks, the routers in the stub area use a default
route which is injected into the area by the Area Border Router (ABR). A stub
area is typically configured in situations where the branch office need not
know about all the routes to every other office, instead it could use a default
route to the central office and get to other places from there. Hence the
memory requirements of the leaf node routers is
reduced, and so is the size of the OSPF database.
To
define an area as a stub area, use the OSPF router configuration command, area
stub
next
Totally
Stub Areas: These areas do not allow routes other than intra-area and the
default routes to be propagated within the area. The ABR injects a default
route into the area and all the routers belonging to this area use the default
route to send any traffic outside the area.
To
define a totally stub area, use the OSPF router
configuration command, area
stub no-summary, on
the ABR.
r3#sh ip route ospf
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:19:58, Serial1/3
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA 10.1.1.0/24 [110/129] via 10.1.23.2, 00:19:58, Serial1/3
O IA 10.1.2.0/24 [110/65] via 10.1.23.2, 00:19:58, Serial1/3
O IA 10.1.12.0/24 [110/128] via 10.1.23.2, 00:19:58, Serial1/3
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:19:58, Serial1/3
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA 10.1.1.0/24 [110/129] via 10.1.23.2, 00:19:58, Serial1/3
O IA 10.1.2.0/24 [110/65] via 10.1.23.2, 00:19:58, Serial1/3
O IA 10.1.12.0/24 [110/128] via 10.1.23.2, 00:19:58, Serial1/3
r3#sh ip ospf data
OSPF Router with ID (10.1.3.1) (Process ID 1)
Router Link States (Area 23)
Link ID ADV Router Age Seq# Checksum Link count
10.1.2.1 10.1.2.1 1297 0x80000007 0x00240A 2
10.1.3.1 10.1.3.1 1296 0x80000007 0x0011FC 3
Summary Net Link States (Area 23)
Link ID ADV Router Age Seq# Checksum
0.0.0.0 10.1.2.1 1333 0x80000001 0x003BF4
10.1.1.0 10.1.2.1 862 0x80000003 0x0020C1
10.1.2.0 10.1.2.1 1333 0x80000006 0x008C91
10.1.12.0 10.1.2.1 1333 0x80000006 0x00963E
r3#
then slam this in r2
r2(config)#router ospf 1
r2(config-router)#area 23 stub no-summary
r2(config-router)#end
r2(config-router)#area 23 stub no-summary
r2(config-router)#end
and behold
r3#sh ip route ospf
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:01:45, Serial1/3
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:01:45, Serial1/3
OSPF Router with ID (10.1.3.1) (Process ID 1)
Router Link States (Area 23)
Link ID ADV Router Age Seq# Checksum Link count
10.1.2.1 10.1.2.1 1045 0x80000008 0x00220B 2
10.1.3.1 10.1.3.1 979 0x80000008 0x000FFD 3
Summary Net Link States (Area 23)
Link ID ADV Router Age Seq# Checksum
0.0.0.0 10.1.2.1 176 0x80000004 0x0035F7
r3#
okay...
NSSA:
This type of area allows the flexibility of importing a few external routes
into the area while still trying to retain the stub characteristic. Assume that
one of the routers in the stub area is connected to an external AS running a
different routing protocol, it now becomes the ASBR, and hence the area can no
more be called a stub area. However, if the area is configured as a NSSA, then
the ASBR generates a NSSA external link-state advertisement (LSA) (Type-7)
which can be flooded throughout the NSSA area. These Type-7 LSAs are converted
into Type-5 LSAs at the NSSA ABR and flooded throughout the OSPF domain
To
define a NSSA, use the OSPF router configuration command, area
nssa no-summary.
For
more information on NSSA, refer to OSPF
Not-So-Stubby Area.
first, lose the stub... then cook it on both sides...
if you don't use the redistribute connected subnets command you will only get classful network redistribution...
r2#sh ip ospf
Routing Process "ospf 1" with ID 10.1.2.1
Start time: 00:00:11.876, Time elapsed: 03:57:07.532
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border and autonomous system boundary router
Redistributing External Routes from,
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 1. Checksum Sum 0x00FA03
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 0 stub 1 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:05:41.308 ago
SPF algorithm executed 10 times
Area ranges are
Number of LSA 4. Checksum Sum 0x028D62
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 23
Number of interfaces in this area is 1
It is a NSSA area
Perform type-7/type-5 LSA translation
Area has no authentication
SPF algorithm last executed 00:03:32.156 ago
SPF algorithm executed 11 times
Area ranges are
Number of LSA 6. Checksum Sum 0x02884C
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
the point, and also below, bringing in lo20...
r2#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O 10.1.1.0/24 [110/65] via 10.1.12.1, 00:07:39, Serial1/1
C 10.1.2.0/24 is directly connected, Loopback2
L 10.1.2.1/32 is directly connected, Loopback2
O 10.1.3.0/24 [110/65] via 10.1.23.3, 00:07:29, Serial1/3
C 10.1.12.0/24 is directly connected, Serial1/1
L 10.1.12.2/32 is directly connected, Serial1/1
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.2/32 is directly connected, Serial1/3
172.16.0.0/24 is subnetted, 1 subnets
O N2 172.16.200.0 [110/20] via 10.1.23.3, 00:05:20, Serial1/3
the N2 makes it special... also, on r1, the default route is gone and E2 shows up for lo20 on r3...
r1#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Loopback1
L 10.1.1.1/32 is directly connected, Loopback1
O 10.1.2.0/24 [110/65] via 10.1.12.2, 01:58:13, Serial1/1
O IA 10.1.3.0/24 [110/129] via 10.1.12.2, 00:16:20, Serial1/1
C 10.1.12.0/24 is directly connected, Serial1/1
L 10.1.12.1/32 is directly connected, Serial1/1
O IA 10.1.23.0/24 [110/128] via 10.1.12.2, 01:58:13, Serial1/1
172.16.0.0/24 is subnetted, 1 subnets
O E2 172.16.200.0 [110/20] via 10.1.12.2, 00:14:10, Serial1/1
another look at r3...
r3#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA 10.1.1.0/24 [110/129] via 10.1.23.2, 00:18:31, Serial1/3
O IA 10.1.2.0/24 [110/65] via 10.1.23.2, 00:18:31, Serial1/3
C 10.1.3.0/24 is directly connected, Loopback3
L 10.1.3.1/32 is directly connected, Loopback3
O IA 10.1.12.0/24 [110/128] via 10.1.23.2, 00:18:31, Serial1/3
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.3/32 is directly connected, Serial1/3
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.200.0/24 is directly connected, Loopback20
L 172.16.200.1/32 is directly connected, Loopback20
note: a default route for nssa is not automatically injected by the abr... but
r3#sh ip route
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*N2 0.0.0.0/0 [110/1] via 10.1.23.2, 00:00:26, Serial1/3
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA 10.1.1.0/24 [110/129] via 10.1.23.2, 00:21:41, Serial1/3
O IA 10.1.2.0/24 [110/65] via 10.1.23.2, 00:21:41, Serial1/3
C 10.1.3.0/24 is directly connected, Loopback3
L 10.1.3.1/32 is directly connected, Loopback3
O IA 10.1.12.0/24 [110/128] via 10.1.23.2, 00:21:41, Serial1/3
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.3/32 is directly connected, Serial1/3
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.200.0/24 is directly connected, Loopback20
L 172.16.200.1/32 is directly connected, Loopback20
guess what this does?
r2(config-router)#no area 23 nssa def
r2(config-router)#no area 23 nssa default-information-originate
r2(config-router)#area 23 nssa no-summ
r3(config)#router ospf 1
r3(config-router)#no area 23 stub
r3(config-router)#
*Aug 5 14:21:56: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
r3(config-router)#area 23 nssa
r3(config-router)#redistribute connected subnets
r3(config-router)#
*Aug 5 14:22:04: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from DOWN to DOWN, Neighbor Down: Adjacency forced to reset
r3(config-router)#
*Aug 5 14:22:44: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from LOADING to FULL, Loading Done
r3(config-router)#
r3(config-router)#no area 23 stub
r3(config-router)#
*Aug 5 14:21:56: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
r3(config-router)#area 23 nssa
r3(config-router)#redistribute connected subnets
r3(config-router)#
*Aug 5 14:22:04: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from DOWN to DOWN, Neighbor Down: Adjacency forced to reset
r3(config-router)#
*Aug 5 14:22:44: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from LOADING to FULL, Loading Done
r3(config-router)#
if you don't use the redistribute connected subnets command you will only get classful network redistribution...
r2#sh ip ospf
Routing Process "ospf 1" with ID 10.1.2.1
Start time: 00:00:11.876, Time elapsed: 03:57:07.532
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 3101)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
It is an area border and autonomous system boundary router
Redistributing External Routes from,
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 1. Checksum Sum 0x00FA03
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 0 stub 1 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:05:41.308 ago
SPF algorithm executed 10 times
Area ranges are
Number of LSA 4. Checksum Sum 0x028D62
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 23
Number of interfaces in this area is 1
It is a NSSA area
Perform type-7/type-5 LSA translation
Area has no authentication
SPF algorithm last executed 00:03:32.156 ago
SPF algorithm executed 11 times
Area ranges are
Number of LSA 6. Checksum Sum 0x02884C
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
the point, and also below, bringing in lo20...
r2#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
O 10.1.1.0/24 [110/65] via 10.1.12.1, 00:07:39, Serial1/1
C 10.1.2.0/24 is directly connected, Loopback2
L 10.1.2.1/32 is directly connected, Loopback2
O 10.1.3.0/24 [110/65] via 10.1.23.3, 00:07:29, Serial1/3
C 10.1.12.0/24 is directly connected, Serial1/1
L 10.1.12.2/32 is directly connected, Serial1/1
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.2/32 is directly connected, Serial1/3
172.16.0.0/24 is subnetted, 1 subnets
O N2 172.16.200.0 [110/20] via 10.1.23.3, 00:05:20, Serial1/3
the N2 makes it special... also, on r1, the default route is gone and E2 shows up for lo20 on r3...
r1#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Loopback1
L 10.1.1.1/32 is directly connected, Loopback1
O 10.1.2.0/24 [110/65] via 10.1.12.2, 01:58:13, Serial1/1
O IA 10.1.3.0/24 [110/129] via 10.1.12.2, 00:16:20, Serial1/1
C 10.1.12.0/24 is directly connected, Serial1/1
L 10.1.12.1/32 is directly connected, Serial1/1
O IA 10.1.23.0/24 [110/128] via 10.1.12.2, 01:58:13, Serial1/1
172.16.0.0/24 is subnetted, 1 subnets
O E2 172.16.200.0 [110/20] via 10.1.12.2, 00:14:10, Serial1/1
another look at r3...
r3#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA 10.1.1.0/24 [110/129] via 10.1.23.2, 00:18:31, Serial1/3
O IA 10.1.2.0/24 [110/65] via 10.1.23.2, 00:18:31, Serial1/3
C 10.1.3.0/24 is directly connected, Loopback3
L 10.1.3.1/32 is directly connected, Loopback3
O IA 10.1.12.0/24 [110/128] via 10.1.23.2, 00:18:31, Serial1/3
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.3/32 is directly connected, Serial1/3
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.200.0/24 is directly connected, Loopback20
L 172.16.200.1/32 is directly connected, Loopback20
note: a default route for nssa is not automatically injected by the abr... but
r2(config)#router ospf 1
r2(config-router)#area 23 nssa default-i
r2(config-router)#area 23 nssa default-information-originate
r2(config-router)#area 23 nssa default-i
r2(config-router)#area 23 nssa default-information-originate
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*N2 0.0.0.0/0 [110/1] via 10.1.23.2, 00:00:26, Serial1/3
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA 10.1.1.0/24 [110/129] via 10.1.23.2, 00:21:41, Serial1/3
O IA 10.1.2.0/24 [110/65] via 10.1.23.2, 00:21:41, Serial1/3
C 10.1.3.0/24 is directly connected, Loopback3
L 10.1.3.1/32 is directly connected, Loopback3
O IA 10.1.12.0/24 [110/128] via 10.1.23.2, 00:21:41, Serial1/3
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.3/32 is directly connected, Serial1/3
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.200.0/24 is directly connected, Loopback20
L 172.16.200.1/32 is directly connected, Loopback20
guess what this does?
r2(config-router)#no area 23 nssa def
r2(config-router)#no area 23 nssa default-information-originate
r2(config-router)#area 23 nssa no-summ
gets rid of the ia's, replaced with a single default...
r3#sh ip route
Gateway of last resort is 10.1.23.2 to network 0.0.0.0
O*IA 0.0.0.0/0 [110/65] via 10.1.23.2, 00:02:19, Serial1/3
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.3.0/24 is directly connected, Loopback3
L 10.1.3.1/32 is directly connected, Loopback3
C 10.1.23.0/24 is directly connected, Serial1/3
L 10.1.23.3/32 is directly connected, Serial1/3
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.200.0/24 is directly connected, Loopback20
L 172.16.200.1/32 is directly connected, Loopback20
r3#
but more importantly... remember above on r2 the link type 7/5 translation?
now you are a totally stubby not so stubby area dude... who made this shit up?
a greasy lightning fast totally stubby not so stubby area monster...
r2#sh ip ospf data
OSPF Router with ID (10.1.2.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 1463 0x80000007 0x0050D9 3
10.1.2.1 10.1.2.1 1179 0x8000000B 0x004DD2 3
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.3.0 10.1.2.1 1425 0x80000002 0x00EDF0
10.1.23.0 10.1.2.1 1179 0x80000009 0x00F8CB
Router Link States (Area 23)
Link ID ADV Router Age Seq# Checksum Link count
10.1.2.1 10.1.2.1 1425 0x8000000D 0x00A578 2
10.1.3.1 10.1.3.1 1377 0x8000000D 0x00926B 3
Summary Net Link States (Area 23)
Link ID ADV Router Age Seq# Checksum
0.0.0.0 10.1.2.1 562 0x80000001 0x00C265
Type-7 AS External Link States (Area 23)
Link ID ADV Router Age Seq# Checksum Tag
172.16.200.0 10.1.3.1 1377 0x80000002 0x005D94 0
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
172.16.200.0 10.1.2.1 1179 0x80000002 0x00F804 0
of course, the chapter just wouldn't be the same if we didn't end on a low note... they always save the best for last... key chains... eeerrrrrrp...
but you love key chains, arteq...
r3(config)#int s1/3
r3(config-if)#ip ospf authentication-key suck-key
r3(config-if)#
*Aug 5 15:46:52: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from LOADING to FULL, Loading Done
r3(config-if)#
r3(config-if)#ip ospf authentication-key suck-key
r3(config-if)#
*Aug 5 15:46:52: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/3 from LOADING to FULL, Loading Done
r3(config-if)#
r2#sh run int s1/3
Building configuration...
Current configuration : 166 bytes
!
interface Serial1/3
ip address 10.1.23.2 255.255.255.0
ip ospf authentication
ip ospf authentication-key suck-key
serial restart-delay 0
clock rate 64000
end
r2#
*Aug 5 15:46:52: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.3.1 on Serial1/3 from LOADING to FULL, Loading Done
r2#sh ip ospf int s1/3
Serial1/3 is up, line protocol is up
Internet Address 10.1.23.2/24, Area 23, Attached via Network Statement
Process ID 1, Router ID 10.1.2.1, Network Type POINT_TO_POINT, Cost: 64
Topology-MTID Cost Disabled Shutdown Topology Name
0 64 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 3
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.1.3.1
Suppress hello for 0 neighbor(s)
Simple password authentication enabled
r2#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 0 FULL/ - 00:00:34 10.1.12.1 Serial1/1
10.1.3.1 0 FULL/ - 00:00:37 10.1.23.3 Serial1/3
and you can make it md5 with
ip ospf authenti message-digest
ip ospf message-digest-key 1 md5 suck-key
on both sides... have fun with that...
No comments:
Post a Comment