since it's frame, i'll be a nice guy and post the configs... go ahead and scrape, vultures...
but first a couple of things...
i'm never going to post the gns3 files, so forget it... why?
because you should build it yourself, that's why... i build everyone from scratch, and you should too... wax on, wax off, danielson... you some kind of girl or something... frame technique; no defense...
also, here's to everyone who bitches about frame... don't do that... i used to think they still teach it because it's tricky and causes routing protocols to do weird shit, which is partially true, i suppose... but there's more... i believe that frame relay lays the foundation for a solid understanding of mpls... learn balance... and if you don't buy that, i don't care...
hq#sh run | begin interface
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
ip address 10.1.123.1 255.255.255.0
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay map ip 10.1.123.3 103
frame-relay map ip 10.1.123.2 102
frame-relay map ip 10.1.123.1 102
no frame-relay inverse-arp
!
*Aug 12 18:55:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/2, changed state to down
east#sh run | begin interface
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.23.2 255.255.255.0
speed auto
duplex auto
!
interface Serial1/2
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay IETF
serial restart-delay 0
clock rate 64000
frame-relay map ip 10.1.123.3 201
frame-relay map ip 10.1.123.2 201
frame-relay map ip 10.1.123.1 201
no frame-relay inverse-arp
west#sh run | begin interface
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.23.3 255.255.255.0
speed auto
duplex auto
!
interface Serial1/3
ip address 10.1.123.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.1.123.3 301
frame-relay map ip 10.1.123.2 301
frame-relay map ip 10.1.123.1 301
no frame-relay inverse-arp
!
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.23.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/22/44 ms
now for the nail biter... the interfaces never match the lab, so the translation part always sucks... a single mistake, and you are troubleshooting till the cows come home... here it is... but if you are doing it with gns3, your interfaces can match mine, you lucky bastards... i use 7200's and a 3640 for the frame switch, in case you hadn't realized...
frame#sh run
Building configuration...
frame-relay switching
!
interface Serial1/0
no ip address
encapsulation frame-relay IETF
no ip route-cache
no ip mroute-cache
frame-relay intf-type dce
frame-relay route 102 interface Serial1/2 201
frame-relay route 103 interface Serial1/3 301
!
interface Serial1/2
no ip address
encapsulation frame-relay IETF
frame-relay intf-type dce
frame-relay route 201 interface Serial1/0 102
!
interface Serial1/3
no ip address
encapsulation frame-relay IETF
no ip route-cache
no ip mroute-cache
clockrate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial1/0 103
!
of course it's correct... i'm michael the network cat, you dumbasses... see below...
hq#sh frame map
Serial1/0 (up): ip 10.1.123.2 dlci 102(0x66,0x1860), static,
IETF, status defined, active
Serial1/0 (up): ip 10.1.123.1 dlci 102(0x66,0x1860), static,
IETF, status defined, active
Serial1/0 (up): ip 10.1.123.3 dlci 103(0x67,0x1870), static,
IETF, status defined, active
east#sh frame map
Serial1/2 (up): ip 10.1.123.3 dlci 201(0xC9,0x3090), static,
IETF, status defined, active
Serial1/2 (up): ip 10.1.123.2 dlci 201(0xC9,0x3090), static,
IETF, status defined, active
Serial1/2 (up): ip 10.1.123.1 dlci 201(0xC9,0x3090), static,
IETF, status defined, active
Serial1/0 (up): ip 10.1.123.2 dlci 102(0x66,0x1860), static,
IETF, status defined, active
Serial1/0 (up): ip 10.1.123.1 dlci 102(0x66,0x1860), static,
IETF, status defined, active
Serial1/0 (up): ip 10.1.123.3 dlci 103(0x67,0x1870), static,
IETF, status defined, active
east#sh frame map
Serial1/2 (up): ip 10.1.123.3 dlci 201(0xC9,0x3090), static,
IETF, status defined, active
Serial1/2 (up): ip 10.1.123.2 dlci 201(0xC9,0x3090), static,
IETF, status defined, active
Serial1/2 (up): ip 10.1.123.1 dlci 201(0xC9,0x3090), static,
IETF, status defined, active
Serial1/3 (up): ip 10.1.123.3 dlci 301(0x12D,0x48D0), static,
CISCO, status defined, active
Serial1/3 (up): ip 10.1.123.2 dlci 301(0x12D,0x48D0), static,
CISCO, status defined, active
Serial1/3 (up): ip 10.1.123.1 dlci 301(0x12D,0x48D0), static,
CISCO, status defined, active
now add ospf, the networks, and make the loopbacks p2p...
you can do that yourselves...
change the priority on east and west to 0 so that hq is guaranteed the dr...
west(config-if)#int s1/3
west(config-if)#ip ospf pri 0
west(config-if)#ip ospf pri 0
east(config-if)#ip ospf pri 0
the point of all this is that the default network type is nonbroadcast, so we have no adjacencies but we'll accomplish this with neighbor statements... simply, it can be performed on a single router, but best practices dictates it on all three..
hq(config)#router ospf 1
hq(config-router)#neigh 10.1.123.2
hq(config-router)#neigh 10.1.123.3
hq(config-router)#
Aug 12 19:58:44: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.3.1 on Serial1/0 from LOADING to FULL, Loading Done
Aug 12 19:58:44: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.2.1 on Serial1/0 from LOADING to FULL, Loading Done
hq(config-router)#
do it on the other 2 anyway, like good little buttsticks...
west(config)#router ospf 1
west(config-router)#neigh 10.1.123.1
west(config-router)#
west(config-router)#neigh 10.1.123.1
west(config-router)#
east(config)#router ospf 1
east(config-router)#neigh 10.1.123.1
east(config-router)#
hq#sh ip ospf neigheast(config-router)#neigh 10.1.123.1
east(config-router)#
Neighbor ID Pri State Dead Time Address Interface
10.1.2.1 0 FULL/DROTHER 00:01:40 10.1.123.2 Serial1/0
10.1.3.1 0 FULL/DROTHER 00:01:55 10.1.123.3 Serial1/0
hq#
just like new york...
east#sh ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 1 FULL/DR 00:01:36 10.1.123.1 Serial1/2
Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 1 FULL/DR 00:01:36 10.1.123.1 Serial1/2
Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 1 FULL/DR 00:01:46 10.1.123.1 Serial1/3
we'll finish tomorrow... i've been at it since 6 am...
What a great design it is ! I am really one of the most fan of Cisco Architect Designer.
ReplyDeleteI have read your post and I really want to know more about it with exciting mind. This article have awesome topics for me and still wait for the new article.
telephony leased line