here we'll change the point-to-point networks to point-to-multipoint links... remove the neighbor statements with the no form of the command on each router as well as any priority first...
hq#sh run | begin router
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
neighbor 10.1.123.3
neighbor 10.1.123.2
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
neighbor 10.1.123.3
neighbor 10.1.123.2
hq#sh run | begin router
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
east#sh run | beg router
router ospf 1
network 10.1.2.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
neighbor 10.1.123.1
router ospf 1
network 10.1.2.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
neighbor 10.1.123.1
east#sh run | beg router
router ospf 1
network 10.1.2.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
router ospf 1
network 10.1.2.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
you get the idea, then lose the ospf priority...
east#sh run int s1/2
Building configuration...
Current configuration : 291 bytes
!
interface Serial1/2
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay IETF
ip ospf priority 0
serial restart-delay 0
clock rate 64000
frame-relay map ip 10.1.123.3 201
frame-relay map ip 10.1.123.2 201
frame-relay map ip 10.1.123.1 201
no frame-relay inverse-arp
Building configuration...
Current configuration : 291 bytes
!
interface Serial1/2
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay IETF
ip ospf priority 0
serial restart-delay 0
clock rate 64000
frame-relay map ip 10.1.123.3 201
frame-relay map ip 10.1.123.2 201
frame-relay map ip 10.1.123.1 201
no frame-relay inverse-arp
Building configuration...
Current configuration : 271 bytes
!
interface Serial1/2
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay IETF
serial restart-delay 0
clock rate 64000
frame-relay map ip 10.1.123.3 201
frame-relay map ip 10.1.123.2 201
frame-relay map ip 10.1.123.1 201
no frame-relay inverse-arp
now for the 3 serials add point-to-multipoint and append the broadcast statement to the frame maps...
hq#sh run int s1/0
Building configuration...
Current configuration : 320 bytes
!
interface Serial1/0
ip address 10.1.123.1 255.255.255.0
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 10.1.123.3 103 broadcast
frame-relay map ip 10.1.123.2 102 broadcast
no frame-relay inverse-arp
Building configuration...
Current configuration : 320 bytes
!
interface Serial1/0
ip address 10.1.123.1 255.255.255.0
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 10.1.123.3 103 broadcast
frame-relay map ip 10.1.123.2 102 broadcast
no frame-relay inverse-arp
note: you won't need the local interface's frame map...
east#sh run int s1/2
Building configuration...
Current configuration : 293 bytes
!
interface Serial1/2
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
serial restart-delay 0
clock rate 64000
frame-relay map ip 10.1.123.3 201 broadcast
frame-relay map ip 10.1.123.1 201 broadcast
no frame-relay inverse-arp
west#sh run int s1/3Building configuration...
Current configuration : 293 bytes
!
interface Serial1/2
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
serial restart-delay 0
clock rate 64000
frame-relay map ip 10.1.123.3 201 broadcast
frame-relay map ip 10.1.123.1 201 broadcast
no frame-relay inverse-arp
Building configuration...
Current configuration : 270 bytes
!
interface Serial1/3
ip address 10.1.123.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 10.1.123.2 301 broadcast
frame-relay map ip 10.1.123.1 301 broadcast
no frame-relay inverse-arp
note the routes are host routes, expected by point-to-multipoint
east#sh ip route | excl L | incl Loop
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O 10.1.1.0/24 [110/65] via 10.1.123.1, 00:04:17, Serial1/2
C 10.1.2.0/24 is directly connected, Loopback2
O 10.1.3.0/24 [110/129] via 10.1.123.1, 00:02:15, Serial1/2
C 10.1.23.0/24 is directly connected, FastEthernet0/0
C 10.1.123.0/24 is directly connected, Serial1/2
O 10.1.123.1/32 [110/64] via 10.1.123.1, 00:04:17, Serial1/2
O 10.1.123.3/32 [110/128] via 10.1.123.1, 00:02:15, Serial1/2
east#sh ip ospf int s1/210.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O 10.1.1.0/24 [110/65] via 10.1.123.1, 00:04:17, Serial1/2
C 10.1.2.0/24 is directly connected, Loopback2
O 10.1.3.0/24 [110/129] via 10.1.123.1, 00:02:15, Serial1/2
C 10.1.23.0/24 is directly connected, FastEthernet0/0
C 10.1.123.0/24 is directly connected, Serial1/2
O 10.1.123.1/32 [110/64] via 10.1.123.1, 00:04:17, Serial1/2
O 10.1.123.3/32 [110/128] via 10.1.123.1, 00:02:15, Serial1/2
Serial1/2 is up, line protocol is up
Internet Address 10.1.123.2/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 10.1.2.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
Topology-MTID Cost Disabled Shutdown Topology Name
0 64 no no Base
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
No comments:
Post a Comment